This discussion is archived
2 Replies Latest reply: Apr 25, 2012 10:44 AM by Laurent RSS

Problem with 10.2.0.5 for 64bits sources on OEL5 ?

Laurent Newbie
Currently Being Moderated
Hello,

I have a problem with 10.2.0.5 installation on a 64 bit platform (OEL5) : repository is a 11.1.0.6 database configured on the same host.

I have downloaded sources on OTN and edelivery (10.2.0.3 for 64 bits and 10.2.0.5 patchset for 64bits) and verified the MD5SUM (they seem to be correct).

I have tried to install it many times by following official doc (http://docs.oracle.com/cd/B16240_01/doc/install.102/e10953/installing_em.htm#CHDGIEFJ) and the MOS docid 784963.1.

Each time I ran the ConfigureGC.pl I have this error in the log file:

+###################################################+
The action configuration is performing
------------------------------------------------------
The plug-in OC4J Configuration Assistant is running

+2+

The plug-in OC4J Configuration Assistant has successfully been performed
------------------------------------------------------
------------------------------------------------------
The plug-in HTTP Server Configuration Assistant is running

+1 [main] ERROR emSDK.config - oracle.sysman.emSDK.conf.TargetReloadException: Error encounterd executing command /u01/app/oracle/oms10g/bin/emctl reload. Oracle Enterprise Manager 10g Release 3 Grid Control+
Copyright (c) 1996, 2007 Oracle Corporation.  All rights reserved.
---------------------------------------------------------------
+/u01/app/oracle/oms10g/bin/emdctl: symbol lookup error: /u01/app/oracle/oms10g/lib/libclntsh.so.10.1: undefined symbol: nnfoboot+

oracle.sysman.emSDK.conf.TargetReloadException: Error encounterd executing command /u01/app/oracle/oms10g/bin/emctl reload.  Oracle Enterprise Manager 10g Release 3 Grid Control
Copyright (c) 1996, 2007 Oracle Corporation.  All rights reserved.
---------------------------------------------------------------
+/u01/app/oracle/oms10g/bin/emdctl: symbol lookup error: /u01/app/oracle/oms10g/lib/libclntsh.so.10.1: undefined symbol: nnfoboot+

+     at oracle.sysman.emSDK.conf.TargetInstaller.reloadTargets(TargetInstaller.java:1539)+
+     at oracle.sysman.emSDK.conf.TargetInstaller.main(TargetInstaller.java:2989)+

The plug-in HTTP Server Configuration Assistant has failed its perform method
------------------------------------------------------
The action configuration has failed its perform method
+###################################################+

And when I look into the make.log (on OMS and Agent), it seems that every component is linked with 32 bits options :

+(if [ "compile" = "compile" ] ; then \+
+     /u01/app/oracle/oms10g/bin/gennttab > ntcontab.c ;\+
+     */usr/bin/gcc -m32 -m32 -c ntcontab.c* ;\+
+     rm -f /u01/app/oracle/oms10g/lib/ntcontab.o ;\+
+     mv ntcontab.o /u01/app/oracle/oms10g/lib/ ;\+
+/usr/bin/ar rv /u01/app/oracle/oms10g/lib/libn10.a /u01/app/oracle/oms10g/lib/ntcontab.o ; fi)+

And off course, every install process is successful.

One of my colleague have reproduced this on an OEL 5.5 64 bits machine

So i have serious doubts on the content of the Oracle sources ... or maybe I have missed a point (but I have tried up to 50 times to reinstall it and it's always the same problem).

If someone knows ...

Regards,
L.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points