4 Replies Latest reply on May 17, 2012 8:53 AM by Sudipto Desmukh

    jdeveloper installation - installer problem

    929255
      I am trying to install jdeveloper (jdevstudio11116install.exe) in a new bea home, in which I have already successfully installed weblogic 10.3.6 with oepe, osb and soa.
      After I choose the middleware home directory, the error says:

      "The product maintenance level of the current installer (Weblogic Server: 10.3.5.0) is not compatible with the maintenance level of the product installed on your system (Weblogic Server: 10.3.6.0) . Please obtain a compatible installer or perform maintenance on your current system to achieve the desired level".

      I tried to install jdeveloper11115 on the same installation, but the error is the same. Is there something wrong with the order of the installation?

      If I provide a different folder it is ok, but a new weblogic installation is required, which is not an option. Is there another version of jdeveloper that would 'sit' on the existing 10.3.6 installation?

      I found similar posts, but they regard upgrading. I am installing from scratch. I do not want to update/upgrade. I have done this without a problem with previous versions (10.3.4 and 10.3.5) of middleware in the same machine. What has changed?
        • 1. Re: jdeveloper installation - installer problem
          Timo Hahn
          You should not install jdev into an existing WLS home. Check https://blogs.oracle.com/onesizedoesntfitall/entry/solution_for_installing_the_adf if you only want to install the adf runtime libraries onto the existing wls.

          Timo
          1 person found this helpful
          • 2. Re: jdeveloper installation - installer problem
            929255
            Is there a jDeveloper installation that is coupled with wls 10.3.6?
            I also tried jDeveloper 11.1.1.5 but its the same.
            • 3. Re: jdeveloper installation - installer problem
              Vidya Bhushan Tipparaju
              This seems to be a bug in 11.1.1.6.
              Try to install jdev 11.1.1.6.0 in different Middleware home.
              May be you have tried to install jdev into the same middleware home where you installed the stand alone wls 10.3.6?
              Install JDev into a new middleware home,then you should not see this error.

              Thanks,
              Bhushan
              • 4. Re: jdeveloper installation - installer problem
                Sudipto Desmukh
                There is no Jdeveloper installation for 11.1.1.6 coupled with WLS 10.3.6. It comes with WLS 10.3.5 only . You will have to install WLS 10.3.6 separately if you need it.

                Quoting Chris Muir from https://blogs.oracle.com/onesizedoesntfitall/entry/adf_runtimes_vs_wls_versions
                Note with the release of JDeveloper 11.1.1.6.0 there is a subtle change in the ADF Runtime to WLS version pairing. The latest ADF Runtimes 11.1.1.6.0 can run against WLS 10.3.6 and 10.3.5.
                This is the first time in the 11.1.1.X branch we've seen a version run on two versions of WLS.
                As such if you have a 10.3.5 WLS server or have just installed WLS 10.3.6 you can also happily install the 11.1.1.6.0 ADF Runtimes on either.
                Customers need to be careful though as this does not imply the opposite.
                If you install WLS 10.3.6, only the ADF Runtimes 11.1.1.6.0 are certified, the 11.1.1.5.0 ADF Runtimes are not (though the 11.1.1.5.0 ADF Runtimes are still of course certified against WLS 10.3.5).
                For your issue see -
                Not able to install Jedeveloper on SOA Suite 11g 11.1.1.6
                Tip - "Make sure you install JDeveloper and WLS+SOA in totally Different middleware homes (different folders)"
                Edited by: Sudipto Desmukh on May 17, 2012 2:21 PM