4 Replies Latest reply: Apr 30, 2012 1:12 PM by 878492 RSS

    OATS and 11i

      I am trying to build some scripts for 11i (11.5.9) in OATS 9.3.1 and I can't start the recording since I get this message:

      Install Forms FT Helper Failure
      No JRE or Jinitiator installed.

      I have jinitiator installed since I can run 11i including forms without problems outside of OATS.

      I tried uninstalling/installing back the jinitiator. I uninstalled also any other java (JRE, etc) so at this point I have only jinitiator I rebooted my machine few times still no luck.

      Any help is greatly appreciated.

      Thank you
        • 1. Re: OATS and 11i

          Unfortunately, OpenScript does not support the Jinitiator 1.1.8. Oracle (Not ATS) also announced the de-support of the Jinitiator 1.1.8 in July 2009, and it is recommended for customers to upgrade their Jinitiator. For your case, we will need to ask the user to upgrade their system to either Jinitiator 1.3 or to JREs in order to work with ATS.

          Do you have the option to upgrade?
          • 2. Re: OATS and 11i
            Thanks for the reply Jean-Baptiste

            We are in the middle of the upgrade for eBusiness suite 11.5.9 to R12 and I am trying to build some scripts for 11.5.9 and for R12 to compare performance for various functional processes. For R12 which uses JRE I have no issues.

            11.5.9 is using jinitiator 1.1.8 and as far as I can know it won't work with any newr version (1.3 or higher). Please correct me if I am wrong.

            So it looks like I am out of luck :-(

            • 3. Re: OATS and 11i
              Hi Christian,

              Not completly out of luck if you don't mind changing the underlying jvm.dll provided by Oracle. I had a whole bunch of issues when the forms module was first released, so I wrote a white paper on this to help ease the pain. You don;t need to follow all the instructions, but the JInitiator environment is discussed.

              Please refer to


              It's a hack, but it will work :)


              • 4. Re: OATS and 11i
                Thanks Wayne. I will try and let you know.

                I had a brief look at your post and have a quick question, do I have to reinstall OpenScript after replacing jvm since it's already installed?