7 Replies Latest reply: May 2, 2012 6:36 AM by Jiri.Machotka-Oracle RSS

    WebCenter Content and BPM

    896109
      Hi,

      I have installed UCM and SOA BPM. Now I need to integrate this products.
      Can somebody advice me how to do this?

      Thanks!
        • 1. Re: WebCenter Content and BPM
          Jiri.Machotka-Oracle
          Read this doc to start: http://docs.oracle.com/cd/E21764_01/doc.1111/e16759/toc.htm

          Note that UCM is integrated with BPEL processes.
          • 2. Re: WebCenter Content and BPM
            896109
            Thank you for usefull guide.

            But after configuring a new connetion http://docs.oracle.com/cd/E21764_01/doc.1111/e16759/c03_config_ucm_bpel001.htm#BABFHEBA the test of it fails.
            Can you help me with conection parameters?

            What does it mean "The BPEL process domain identifier."
            As provider URL I use      host-name:8001/soa-infra

            Thanks!
            • 3. Re: WebCenter Content and BPM
              Jiri.Machotka-Oracle
              Can you help me with conection parameters?
              And how is your SOA and UCM installed? I've got it installed in the same Weblogic domain and 'default' setting work for 'Domain'. Otherwise, you might have to use the name of the Weblogic domain where SOA is installed.

              As for the 'Provider URL' I just replaced the placeholder in the initial value by the IP address - now it looks as t3://192.168.56.72:8001/soa-infra
              • 4. Re: WebCenter Content and BPM
                896109
                I have installed UCM and SOA to the same domain too. I've left the 'default' setting for 'Domain' field and specified t3://192.168.xx.xx:8001/soa-infra in 'Provider URL'.
                In the field "The Initial Context Factory" I've left default value weblogic.jndi.WLInitialContextFactory. And as "Security Principal" I've specified my weblogic administrator user "weblogic".
                But connection test still fails.
                Thanks!
                • 5. Re: WebCenter Content and BPM
                  Jiri.Machotka-Oracle
                  I'm afraid it can be anything.

                  I have just faced a similar issue - I cannot connect to the SOA server (in a VirtualBox VM) from my JDev (at the host), even though everything seems to be OK.

                  Having said that, try to verify that you can make a connection to the SOA server (probably, JDev is a good option here, but do not forget to turn off using proxy in JDev). If that is possible, but UCM still cannot connect to SOA, probably something in the manual has not been done correctly. Or, your system just has its 'issues'. I'd be in my wits' end here - possibly someone with deeper Weblogic knowledge will be required to resolve this.
                  • 6. Re: WebCenter Content and BPM
                    896109
                    I have one anoather installation on this server but in anoather domain and connection is fine there.
                    Now I am trying to configure a new process. http://docs.oracle.com/cd/E21764_01/doc.1111/e16759/c03_config_ucm_bpel002.htm#BEIDAABA
                    "BPEL Process      The process identifier of a deployed, active BPEL process. Each active process is listed with the Process Name and Process Revision. The default revision for each process is identified with an asterisk (*)."
                    Where can I create, deploy and activate BPEL process?
                    Thanks!
                    • 7. Re: WebCenter Content and BPM
                      Jiri.Machotka-Oracle
                      Where can I create, deploy and activate BPEL process?
                      This is more a BPEL (SOA) question than a UCM one. Are you sure that you have everything OK on the BPEL side?

                      In a nutshell, BPEL processes are best created in JDeveloper (it is a bunch of XMLs, so you could use other means to get them, but JDev will give you much better support, incl. deployment). A process is deployed on BPEL Process Manager (or BPM Engine); a J2EE app running on Weblogic.

                      UCM just reads what processes are available on BPEL PM. I'm just studying the matter in a bit deeper way, so it seems that a process must have a certain properties set to be recognized (see here: Re: UCM 11G and SOA 11G ). And, of course, the connection between UCM and BPEL PM (or SOA server) must be set first - I'm currently struggling with this one as ports to be read seemed to be filtered off, and I'm unable to connect to the server. That's why I'd recommend to narrow down the problem first.