2 Replies Latest reply on May 7, 2012 10:59 AM by Ana

    API-5022 in accessing  the Design Editor


      I've working with my Workspace - user (repository owner) - Project in the Design Center for a long time. This week the emkey.ora file get corrupted and the backup was unavailable, so I`ve to recreate the Enterprise Manager Console repository in order to access to the Enterprise Manager Console for the database. It was ok, and the console is available again, but when I tried to access the Design Center with the repository owner I get the following error message:

      API5022: No se puede conectar a la cuenta especificada. Compruebe la información de conexión

      I've been searching info about this error and I've already tried:

      - The NAMESPACESERIVEIMPL package is valid
      - The workspace owner has already granted permission above the V_$SESSION
      - I can connect with that user in SQL*Plus with no problem
      - I cannot connect with that user through the Design Editor in another client installation (Windows client) from the same release than this (
      - I've tried creating another user with access to that workspace from the repository assistant, but I get the error java.lang.Exception:Null, and I've not able to see anything else in the log file (I can include an extract if it could help anybody to see what happens! )

      Platform: Linux
      DB Version:

      I was thinking about two options, but I cannot find documentation about them, and I don`t know if they could damage, even more, the repository:
      - recreate the emconsole, just in case something not detected went wrong.
      - create another workspace with same owner, to see if I can access Design Editor, and I can do something else from within.... but as I say, I don`t know their implications (if I can lose the actual workspace forever, for example)...

      I don't know what else to try, so any help will be greatly appreciated!

        • 1. Re: API-5022 in accessing  the Design Editor

          I've also tried connecting through OMBPlus using the repository owner. but it gives the following error message:
          OMB01118: It could not connect to the repository. null

          A weird thing for me is that there is no more explanation about the general error ('null' instead a message more concrete). ??

          I've also tried connecting to Design Editor as another user allowed to access to that workspace, but the error is the same than with the repository owner.

          Please, any idea? Anything to check? If this cannot be fixed, is there any way to export a project, other than connecting to the Design Editor / OMBPlus using the rep_owner user?

          Thanks in advance,
          • 2. Re: API-5022 in accessing  the Design Editor

            In case this may help anybody:

            After analyzing all objects of the OWBSYS schema, comparing them with the OWBSYS schema of another repository that was working OK, I have found that 8 indexes where in status 'Unusable', so I have rebuild those indexes from SQL*Plus and now I can access the Design Editor.