1 Reply Latest reply on Apr 30, 2012 11:17 AM by Prabodh

    Javascript errors in Apex when Apex Listener is running under Glassfish

    JPL_12
      I'm struggling to get Apex Listener working under Glassfish on my new laptop.

      Apex 4.1.1, Oracle 10.2.0.5, Windows 7 64 bit, GlassFish Server Open Source Edition 3.1.1 (build 12).

      I have a strange behavior of Apex under Glassfish.

      I click 'Add row' on the detail region (the tabular form) on my Master - Detail page.
      The row appears, but after clicking 'Apply changes' it's gone again.
      Using Firebug, I see that the javascript causes an "gErrItems is undefined" error, something coming from apex_4_1.min.js

      The same application works fine on my old laptop, so I finally figured out that starting apex_listener from the command prompt solved the javascript error.

      What can be the problem?
      Is Glassfish not compatible with my configuration?
        • 1. Re: Javascript errors in Apex when Apex Listener is running under Glassfish
          Prabodh
          Nothing to do with Glassfish compatibility. Perhaps your setup is not complete.

          Have you copied all the contents of the apex/images folder of the installables into the glasshish <domain>/docroot folder?

          And you #IMAGE_PREFIX# is /i/ and not /images/ ?

          And is your OWA_UTIL version at least 10.0.2.6? In other words, have you installed the OWA_UTIL shipped in the apex installables?

          Regards,

          Edited by: Prabodh on Apr 30, 2012 1:12 PM