This discussion is archived
6 Replies Latest reply: May 3, 2012 9:18 AM by N K RSS

bug with impdp?

N K Pro
Currently Being Moderated
Hello Folks,

I've been migrating a schema across diferent databases.

Source is Oracle Linux 5.7 and DB is 11.2.0.7
Target is Windows Server 2008 and DB is 11.2.0.7

Since I was doing Table exports, when I fired IMPDP in my parfile I included "FROMUSER=GX TOUSER=GX" (just to be safe, since I was issuing the import as SYSTEM and didnt want objects to be imported into SYSTEM). So IMPDP would enter Legacy Mode and change it to REMAP_SCHEMA or whatever it needs to do

However, while doing the import the import tries to create things as "GX "."<TABLE_NAME>" ..please notice the blank space after the schemaname

If I take out the fromuser/touser or remap_schema it will work properly.. but shouldnt the options I am giving work properly aswell? Is this a problem because source is Linux and target is Windows?

Can anyone explain this behaviour?

Thanks
  • 1. Re: bug with impdp?
    sb92075 Guru
    Currently Being Moderated
    N K wrote:
    Hello Folks,

    I've been migrating a schema across diferent databases.

    Source is Oracle Linux 5.7 and DB is 11.2.0.7
    Target is Windows Server 2008 and DB is 11.2.0.7

    Since I was doing Table exports, when I fired IMPDP in my parfile I included "FROMUSER=GX TOUSER=GX" (just to be safe, since I was issuing the import as SYSTEM and didnt want objects to be imported into SYSTEM). So IMPDP would enter Legacy Mode and change it to REMAP_SCHEMA or whatever it needs to do

    However, while doing the import the import tries to create things as "GX "."<TABLE_NAME>" ..please notice the blank space after the schemaname

    If I take out the fromuser/touser or remap_schema it will work properly.. but shouldnt the options I am giving work properly aswell? Is this a problem because source is Linux and target is Windows?

    Can anyone explain this behaviour?

    Thanks
    impdp help=yes

    please post URL to where FROMUSER & TOUSER are documented for impdp.
  • 2. Re: bug with impdp?
    N K Pro
    Currently Being Moderated
    sb92075 wrote:
    N K wrote:
    Hello Folks,

    I've been migrating a schema across diferent databases.

    Source is Oracle Linux 5.7 and DB is 11.2.0.7
    Target is Windows Server 2008 and DB is 11.2.0.7

    Since I was doing Table exports, when I fired IMPDP in my parfile I included "FROMUSER=GX TOUSER=GX" (just to be safe, since I was issuing the import as SYSTEM and didnt want objects to be imported into SYSTEM). So IMPDP would enter Legacy Mode and change it to REMAP_SCHEMA or whatever it needs to do

    However, while doing the import the import tries to create things as "GX "."<TABLE_NAME>" ..please notice the blank space after the schemaname

    If I take out the fromuser/touser or remap_schema it will work properly.. but shouldnt the options I am giving work properly aswell? Is this a problem because source is Linux and target is Windows?

    Can anyone explain this behaviour?

    Thanks
    impdp help=yes

    please post URL to where FROMUSER & TOUSER are documented for impdp.
    If you put it into a parfile it will activate "Legacy mode" and put it into a REMAP_SCHEMA parameter. The functionality is there.
  • 3. Re: bug with impdp?
    mseberg Guru
    Currently Being Moderated
    Hello;

    Maybe check this under "How Data Pump Import Parameters Map to Those of the Original Import Utility"

    http://docs.oracle.com/cd/B28359_01/server.111/b28319/dp_import.htm#i1006538

    Also I'm thinking your Oracle version is 11.1.0.7

    Best Regards

    mseberg
  • 4. Re: bug with impdp?
    sb92075 Guru
    Currently Being Moderated
    N K wrote:

    If you put it into a parfile it will activate "Legacy mode" and put it into a REMAP_SCHEMA parameter. The functionality is there.
    then file a bug report.
  • 5. Re: bug with impdp?
    mseberg Guru
    Currently Being Moderated
    Hello again;

    Correct me if I'm wrong but

    Using Original Export Parameters with Data Pump -

    http://docs.oracle.com/cd/E11882_01/server.112/e22490/dp_legacy.htm

    I don't see FROMUSER as an option.

    OK, I'm wrong. Look further at that same document.

    is this the catch?

    The FROMUSER parameter must also have been specified in original Import or the operation will fail.


    Best Regards

    mseberg

    Edited by: mseberg on May 3, 2012 11:13 AM

    Edited by: mseberg on May 3, 2012 11:14 AM
  • 6. Re: bug with impdp?
    N K Pro
    Currently Being Moderated
    mseberg wrote:
    Hello;

    Maybe check this under "How Data Pump Import Parameters Map to Those of the Original Import Utility"

    http://docs.oracle.com/cd/B28359_01/server.111/b28319/dp_import.htm#i1006538

    Also I'm thinking your Oracle version is 11.1.0.7

    Best Regards

    mseberg
    Thanks.

    I've also found that my target was 11.2.0.1 and this was fixed on 11.2.0.2 Patch Set

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points