This discussion is archived
3 Replies Latest reply: May 4, 2012 1:46 AM by 924908 RSS

Create a new resource but not onlining it

924908 Newbie
Currently Being Moderated
Hello,

I want to create a new resource but it should not start after creation.
Resourcegroup Test is online and contain several resources.

Tried to set:

clrg set -p Auto_start_on_new_cluster=FALSE Test

but that didn't work. The new resource starts after creation.
Perhaps Auto_start_on_new_cluster is not the correct parameter?!

Sun Cluster 3.3

Any hints?

Regards,
Heinz
  • 1. Re: Create a new resource but not onlining it
    924908 Newbie
    Currently Being Moderated
    Ok,

    Auto_start_on_new_cluster is not the correct parameter ( man rg_properties ).

    Any hints?

    Regrads,
    Heinz
  • 2. Re: Create a new resource but not onlining it
    Nik Expert
    Currently Being Moderated
    Hi.

    According
    http://docs.oracle.com/cd/E18728_01/html/821-2679/rg-properties-5.html#scrolltoc

    This properties affect on another things.

    "If set to FALSE, the resource group does *not start* automatically when the *cluster is rebooted*. The resource group remains offline until the first time that the resource group is manually switched online by using the clresourcegroup(1CL) command or the equivalent graphical user interface command. After that, the resource group resumes normal failover behavior."


    According
    http://docs.oracle.com/cd/E18728_01/html/821-2679/clresource-1cl.html#SCREFMANclresource-1cl

    You can disable resource when create it.

    "-d
    --disable
    Disables a resource when the resource is created. You can specify this option only with the create subcommand. By default, resources are created in the enabled state."

    Regards.
  • 3. Re: Create a new resource but not onlining it
    924908 Newbie
    Currently Being Moderated
    Nik, that did the trick ;-))

    Thanks!


    Regards,
    Heinz

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points