0 Replies Latest reply on May 5, 2012 10:26 AM by LPNO

    Your first Cup: DukesAge; build-impl.xml:739: module not been deployped

      I tried to run my very first IEE app with the new Tutorial doku Your first Cup: An Introduction to the Java EE Plattform 821-1770-14/April 2012

      The small app of Chapter 3 will (no more) build and deploy.
      I do exactly as descriped. After 3 trials I had it running and I got the expected output: 16
      After a restart of my computer, it would not work anymore. I tried to rebuild the small app from scratch in dukes-age2 to dukes-age6. Allways the same, it doesn't work ...

      when I try to run the app I get an error in netbeans console:

      In-place deployment at D:\Wrk\OLI3\Eclipse.Git\Dev.Java\iee\dukes-age5\build\web
      deploy?DEFAULT=D:\Wrk\OLI3\Eclipse.Git\Dev.Java\iee\dukes-age5\build\web&name=dukes-age5&contextroot=/DukesAgeService&force=true failed on GlassFish Server 3+
      Datei nicht gefunden: D:\Wrk\OLI3\Eclipse.Git\Dev.Java\iee\dukes-age5\build\web
      D:\Wrk\OLI3\Eclipse.Git\Dev.Java\iee\dukes-age5\nbproject\build-impl.xml:739: The module has not been deployed.
      See the glassfish server log for details.
      BUILD FAILED (total time: 1 second)

      the offending line in the build is:

      <target if="netbeans.home" name="-run-deploy-nb">
      <nbdeploy clientUrlPart="${client.urlPart}" debugmode="false" forceRedeploy="${forceRedeploy}"/>

      I tried to look at the the glassfish-server log. I' can't see anything offending there. Only one warning:

      Meldungs-ID PWC4011
      Vollständige Meldung Unable to set request character encoding to UTF-8 from context , because request parameters have already been read, or ServletRequest.getReader() has already been called
      my language setting are: swiss-german. This should not be relevant.

      What means:
      Datei nicht gefunden: D:\Wrk\OLI3\Eclipse.Git\Dev.Java\iee\dukes-age5\build\web eg.
      File not found: D:\Wrk\OLI3\Eclipse.Git\Dev.Java\iee\dukes-age5\build\web
      web is a folder not a file. It contains two more foldes: WEB-INF, META-INF

      What's does this crypted error message try to say'
      What's going wrong?
      How can I make this really simple sample again make running?

      Please help is needed...