2 Replies Latest reply: May 8, 2012 6:36 AM by user9321223 RSS

    Newbie: What version of WL is needed to use the experimental WL plugins?

    user9321223
      I've successfully installed and connected to 10.3.5 on jrockit r28, but am having trouble with 10.3.2 on r28. The WLDFDiagnosticVolume property is not available on the managed nodes, for example. I'm able to connect to 10.3.2 and see the JRockit JMX counters just fine, but I'm looking for the WebLogic WLDF JDBC counters in particular. They're not there. Is there a workaround for different versions of WL?

      And for kickers, my JR Mission Control installation seems to have developed some bit-rust, too. I was able to run "Help\Install Plug-ins... (Unsupported)" once and installed all sorts of stuff. Now, however, it won't work. It complains there are no features on the selected site and tells me to choose another one.

      Thanks for any guidance, including working links to help docs. :-)
        • 1. Re: Newbie: What version of WL is needed to use the experimental WL plugins?
          Arunbodap-Oracle
          WLDFDiagnosticVolume is available only from WLS10.3.3, so that is the reason why you do not find this property in WLS10.3.2
          We do not have any similar properties for WLS10.3.2 as JFR (JRockit Flight Recording) is not integrated with WebLogic WLDF framework before WLS10.3.2
          The property and the features that use this property are all only introduced in WLS10.3.3, i.e., this property or a similar property will not be useful (not required) in WLS10.3.2 as no collection will use it

          Also, in-order to use JRockitR28.0 for releases older than WLS10.3.3, i.e., WLS10.3.2, WLS9.2MP4 etc.., we would need to apply patch#9884941
          Please do understand that applying this patch is to only fix a few WLS known product issues with JRockitR28 only. This patch will not introduce the WLDF integration features with JFR (WLDFDiagnosticVolume will still not be available with this patch). WLDF integration with JFR is a new feature that is only available from WLS10.3.3.
          Again, this is only required if you want to run WLS10.3.2 using JRockitR28.x

          Regarding the plug-ins, I have personally not tried it.
          But, it looks like you have installed all the plug-ins that were available on that experimental site. I believe that you might not have any further plug-ins that are available there for you to install.


          Arun