6 Replies Latest reply on May 9, 2012 6:58 AM by user13549752

    Login issue using SCAN

    user13549752
      Hi,

      I have a 10.2.0.5 database running on 11.2.0.2 2 node RAC system. When i am using the VIP in my tns entry i am able to login to the database. when i am using the SCAN in my tns entry it is throwing error.

      CASE1: Tns entry using VIP and connection is fine

      OISQ1 =
      (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = NODE1-vip)(PORT = 1521))
      (ADDRESS = (PROTOCOL = TCP)(HOST = NODE2-vip)(PORT = 1521))
      (LOAD_BALANCE = yes)
      (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = oisq1.fmr.com)
      )
      )

      oracle@oidqwlk1:oisq11> sqlplus sys@OISQ1 as sysdba

      SQL*Plus: Release 10.2.0.5.0 - Production on Tue May 8 04:48:52 2012

      Copyright (c) 1982, 2010, Oracle. All Rights Reserved.

      Enter password:

      Connected to:
      Oracle Database 10g Enterprise Edition Release 10.2.0.5.0 - 64bit Production
      With the Partitioning, Real Application Clusters, OLAP, Data Mining
      and Real Application Testing options

      SQL>

      CASE2:Tns entry using SCAN and connection is not happening
      OISQ1_new =
      (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = SCAN_NAME)(PORT = 1521))
      (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME=oisq1.fmr.com)
      )
      )

      oracle@oidqwlk1:oisq11> sqlplus sys@OISQ1_new as sysdba

      SQL*Plus: Release 10.2.0.5.0 - Production on Tue May 8 04:50:06 2012

      Copyright (c) 1982, 2010, Oracle. All Rights Reserved.

      Enter password:
      ERROR:
      ORA-12514: TNS:listener does not currently know of service requested in connect
      descriptor