2 Replies Latest reply: May 8, 2012 9:20 AM by WollemiLover RSS

    Oc 11gR1 update 3: doesn't show ZFS file systems created on brownfield zone

    WollemiLover
      Subject is a pretty concise description here. I have several brownfield Solaris 10U10 containers running on M5000s, and I have delegated three zpool to each container for use by Oracle. Below is relevant output from zonecfg export for one of these containers. They were all built in the same manner, then placed under management by OC. (Wish I'd been able to build them as green field with Ops Center, but there just wasn't enough time to learn how to configure OpsCenter the way I needed to use it.)

      set name=Oracle-DB-Instance
      set type=string
      set value="Oracle e-Business Suite PREPROD"
      end
      add dataset
      set name=PREPRODredoPOOL
      end
      add dataset
      set name=PREPRODarchPOOL
      end
      add dataset
      set name=PREPRODdataPOOL
      end

      The problem is, none of the file systems built on these delegated pools in the container appear in the Ops Center File System Utilization charts. Does anyone have a suggestion for how to get OC to monitor the file systems in the zone?

      Here's the output from zfs list within the zone described by the zonecfg output above:

      [root@acdpreprod ~]# zfs list
      NAME USED AVAIL REFER MOUNTPOINT
      PREPRODarchPOOL 8.91G 49.7G 31K none
      PREPRODarchPOOL/d05 8.91G 49.7G 8.91G /d05
      PREPRODdataPOOL 807G 364G 31K none
      PREPRODdataPOOL/d02 13.4G 36.6G 13.4G /d02
      PREPRODdataPOOL/d03 782G 364G 782G /d03
      PREPRODdataPOOL/d06 11.4G 88.6G 11.4G /d06
      PREPRODredoPOOL 7.82G 3.93G 31K none
      PREPRODredoPOOL/d04 7.82G 3.93G 7.82G /d04

      None of the file systems in the delegated datasets appear in Ops Center for this zone. Are there any suggestions for how I correct this?