1 Reply Latest reply on May 14, 2012 4:35 AM by 830065

    Trying to get ARCO to connect to an Oracle RAC database service name

    830065
      I'm using Grdi Engine 6.2u7 and am trying to get ARCO to connect to a backend Oracle RAC database using the service name. So far I have been successful in getting ARCO to connect using the instance name but if the RAC service fails-over to another database node the instance name will change and ARCO will loose it's database connection.

      In the following examples the values used are:
      - RAC scan name: scan.domain
      - Server names: host_1 and host_2
      - Instance names: arco_1 on server host_1 and arco_2 on host_2
      - Service name: arco.domain

      As mentioned above, using the instance name ARCO can connect to the database with the following url:
      DBWRITER=jdbc:oracle:thin:@scan.domain:1521:arco_1

      I tried to get it to connect using the service name:
      DBWRITER=jdbc:oracle:thin:@scan.domain:1521:arco.domain

      but get an error:
      ../sgedbwriter: syntax error at line5: `DBWRITER_URL=jdbc:oracle:thin:@'

      I then editted dbwriter.conf and tried enclosing the url with quotes, first single quotes then double quotes, but then get a different error in both cases:
      - dbwriter.ReportingDBWriter.run|E|Database type for url <the url string> is not supported

      I have also tried a couple of examples I found on the net:
      DBWRITER=jdbc:oracle:thin:@(DESCRIPTION=(LOAD_BALANCE=on)(ADDRESS=(PROTOCOL=TCP)(HOST=host_1)(PORT=1521))(ADDRESS=(PROTOCOL=TCP)(HOST=host_2)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=arco.domain)(FAILOVER_MODE=(TYPE=SELECT)(METHOD=BASIC)(RETRIES=180)(DELAY=5))

      DBWRITER=jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=scan.domain)(PROTOCOL=TCP)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=arco.domain))

      DBWRITER=jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(HOST=scan.domain)(PROTOCOL=TCP)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=arco.domain)))

      but the error messages are the same.

      I should also mention that the jdbc driver is ojdbc14.jar

      Has anyone else been able to use a RAC database for ARCO?
        • 1. Re: Trying to get ARCO to connect to an Oracle RAC database service name
          830065
          A friendly DBA has pointed out that the format of the url is incorrect for a service.

          When using a service you use forward slashes. For example:
          DBWRITER=jdbc:oracle:thin:@//scan.domain:1521/arco.domain

          When using a database instance name you use colons. For example:
          DBWRITER=jdbc:oracle:thin:@scan.domain:1521:arco_1

          This works fine in dbwriter.conf but I am still trying to make it work in the Reporting config.xml file.