2 Replies Latest reply on Jan 14, 2013 5:03 PM by Joshua Huber

    Error Message 17001

      I'm having trouble getting connected to oracle 10g databases with the latest version of SQL Developer, the original issue I was having I was able to find a lot of help solving. This issue was a message "no ocijdbc11 found", I have since done several different methods to try and remedy this problem. The most recent was suggested in https://kr.forums.oracle.com/forums/thread.jspa?threadID=644299&start=15&tstart=0 and that was to get ahold of the ocijdbc11.dll and copy it into my oracle 10g folder.

      Since doing this the error message has changed to:
      "Internal Error: Fetch error message failed! Vendor code 17001"

      Does anyone know how to fix this error?

      Edited by: 933759 on May 11, 2012 6:13 AM
        • 1. Re: Error Message 17001
          Jim Smith
          1) Download and install an 11g client. The latest version of SQL Developer requires an 11g client if you are using the thick/OCI driver.


          2) Don't use the OCI driver. Tools > Preferences > Database > Advanced. UNcheck Use OCI/Thick Driver
          • 2. Re: Error Message 17001
            Joshua Huber
            I had the same error. What worked for me was going into Registry Editor and delete the NLS_LANG key, found under HKEY_LOCAL_MACHINE > SOFTWARE > ORACLE_HOME. Then closed and reopened SQL Developer and problem was gone.