4 Replies Latest reply: May 21, 2012 5:28 AM by Akanksha Sheoran Kaler RSS

    EM 12c installation - Error  while doing Plugins Prerequisites Check

    864480
      Hello,

      I am trying to install Oracle Enterprise Manager 12c 64bits on Windows Server 2003 SP2, but the Plugins Prerequisites Check fails showing the following errors on the log:

      2012-05-17 15:59:30,779 [main] WARN pluginca.PluginCADriver -
      2012-05-17 15:59:30,779 [main] WARN pluginca.PluginCADriver - ---------------------------------------------------------------
      2012-05-17 15:59:30,779 [main] WARN pluginca.PluginCADriver - ---Plugins On Which Action "Prereq check" Is To Be Performed---
      2012-05-17 15:59:30,779 [main] WARN pluginca.PluginCADriver - oracle.sysman.db=12.1.0.2.0
      2012-05-17 15:59:30,779 [main] WARN pluginca.PluginCADriver - oracle.sysman.xa=12.1.0.2.0
      2012-05-17 15:59:30,779 [main] WARN pluginca.PluginCADriver - oracle.sysman.emas=12.1.0.2.0
      2012-05-17 15:59:30,779 [main] WARN pluginca.PluginCADriver - oracle.sysman.mos=12.1.0.2.0
      2012-05-17 15:59:30,779 [main] WARN pluginca.PluginCADriver - ---------------------------------------------------------------
      2012-05-17 15:59:30,779 [main] WARN pluginca.PluginCADriver -
      2012-05-17 15:59:30,920 [main] WARN deploymentservice.EMPluginDeploymentUtil - No OMS name property passed. Assuming there is only one entry in emInstanceMapping.properties.
      2012-05-17 15:59:31,811 [main] WARN deploymentservice.EMPluginDeploymentUtil - No OMS name property passed. Assuming there is only one entry in emInstanceMapping.properties.
      2012-05-17 15:59:31,842 [main] WARN pluginca.PluginCABackup - No connection passed. Not storing any backup info in repo.
      2012-05-17 15:59:31,842 [main] WARN pluginca.PluginCABackup - No connection passed. Not storing any backup info in repo.
      2012-05-17 15:59:31,842 [main] WARN pluginca.PluginCABackup - No connection passed. Not storing any backup info in repo.
      2012-05-17 15:59:32,170 [main] ERROR pluginca.PluginCADriver - Error while performing Pre config module for plugin oracle.sysman.mos:12.1.0.2.0:0
      Error is: ERROR_IN_CUSTOM_CONFIG( Exception while performing custom config )
      Aborting config for the plugin and all other dependent plugins.
      2012-05-17 15:59:32,186 [main] ERROR pluginca.PluginCADriver - ERROR_IN_CUSTOM_CONFIG( Exception while performing custom config )
      oracle.sysman.core.common.extensibility.pluginca.PluginCAException: ERROR_IN_CUSTOM_CONFIG( Exception while performing custom config )
           at oracle.sysman.core.common.extensibility.pluginca.PluginCAHelper.performCustomConfig(PluginCAHelper.java:702)
           at oracle.sysman.core.common.extensibility.pluginca.PluginCAHelper.preDeployCustomConfig(PluginCAHelper.java:567)
           at oracle.sysman.core.common.extensibility.pluginca.PreConfigModuleStep.preDeploy(PreConfigModuleStep.java:165)
           at oracle.sysman.core.common.extensibility.pluginca.PreConfigModuleStep.run(PreConfigModuleStep.java:87)
           at oracle.sysman.core.common.extensibility.pluginca.PreConfigModuleExecutor.run(PreConfigModuleExecutor.java:46)
           at oracle.sysman.core.common.extensibility.pluginca.PluginCA.preqreqCheck(PluginCA.java:790)
           at oracle.sysman.core.common.extensibility.pluginca.PluginCA.configure(PluginCA.java:326)
           at oracle.sysman.core.common.extensibility.pluginca.PluginCADriver.initPluginCA(PluginCADriver.java:1798)
           at oracle.sysman.core.common.extensibility.pluginca.PluginCADriver.beginConfig(PluginCADriver.java:978)
           at oracle.sysman.core.common.extensibility.pluginca.PluginCADriver.main(PluginCADriver.java:1997)
      Caused by: oracle.sysman.emInternalSDK.core.extensibility.pluginca.PluginCustomConfigException: Cannot access inventory of the Oracle Home..
           at oracle.sysman.config.MosPluginCustomConfig.doPreDeployConfig(MosPluginCustomConfig.java:114)
           at oracle.sysman.core.common.extensibility.pluginca.PluginCAHelper.performCustomConfig(PluginCAHelper.java:692)
           ... 9 more
      Caused by: oracle.opatch.opatchsdk.OPatchException: Cannot access inventory of the Oracle Home..
           at oracle.opatch.opatchsdk.OPatchContext.getInventory(OPatchContext.java:413)
           at oracle.opatch.opatchsdk.OPatchContext.<init>(OPatchContext.java:383)
           at oracle.opatch.opatchsdk.OPatchContext.getInstance(OPatchContext.java:157)
           at oracle.sysman.config.MosPluginCustomConfig.doPreDeployConfig(MosPluginCustomConfig.java:86)
           ... 10 more
      2012-05-17 15:59:32,186 [main] ERROR pluginca.PluginCADriver - Error while performing Pre config module for plugin oracle.sysman.emas:12.1.0.2.0:20120427
      Error is: ERROR_IN_CUSTOM_CONFIG( Exception while performing custom config )
      Aborting config for the plugin and all other dependent plugins.


      Some information:
      - this is an installation from scratch using the graphical installation wizard.
      - database for repository is Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production
      - all EM prerequisites checks for repository (command line tool) succeeded
      - WL server version is 12.1.1.0

      Has anyone come across this problem before?

      Many thanks
      Angel
        • 1. Re: EM 12c installation - Error  while doing Plugins Prerequisites Check
          EricvdS
          Could be the inventory is corrupted for some reason. See note (non Windows):
          Opatch error: "Inventory load failed... OPatch cannot load inventory for the given Oracle Home." [ID 864117.1]
          You can do a opatch lsinventory to see if the inventory is ok.

          I installed EM12c on W2008R2 last week and did not have any problem.

          Eric
          • 2. Re: EM 12c installation - Error  while doing Plugins Prerequisites Check
            864480
            Hi,

            thanks for your reply.
            I finally managed to go beyond the prerequisites step but the installation gets now stuck on the OMS configuration step.

            I don't know which was exactly the problem with the prerequisites phase. I realized that I was not using the right version of WebLogic (which must be Oracle WebLogic Server 11g Release 1 (10.3.5)).
            So, I uninstalled the existing WebLogic 12.1.1.0 and removed also the existing Oracle Home folder, since there was no other products installed on it.

            So, after doing these steps, the prerequisites check was successful, but now it gets stuck on the OMS configuration step.
            After closing the Wizard, I run the OMS configuration assistant again, and I get the following error:

            (in omsca log)
            oracle.sysman.omsca.util.ProcessOutputReader run
            FINE: Code of Exception: Error occured while performing nmConnect : Cannot connect to Node Manager. : Connection refused: connect. Could not connect to NodeManager. Check that it is running at +<HOSTNAME>+:7401.
            Seems like the Weblogic instance could not be started.
            Any ideas?

            Thanks
            Angel
            • 3. Re: EM 12c installation - Error  while doing Plugins Prerequisites Check
              EricvdS
              You do have a service called OracleWeblogicNodeManager_EMGC_OMS1_1?
              And can it be started manually or does it give an error?

              Eric
              • 4. Re: EM 12c installation - Error  while doing Plugins Prerequisites Check
                Akanksha Sheoran Kaler
                can also check if the port are empty, the old wls process is not stuck on the port and thats why the installer is not able to comunicatie to the node manager