3 Replies Latest reply: Jun 13, 2013 9:34 AM by rukbat RSS

    Solaris 11 on Xeon E5 / C600-A / Intel S2600CO - kernel panic

    938387
      I am trying to boot Solaris 11 on a brand new system based on the new Intel S2600CO (Copper-Pass) motherboard. This is based on the Intel C600-A chipset, and is meant to be certified for Solaris 10 U9. The CPU is a Xeon E5-2603.

      However I am getting a kernel panic during startup, very early in the boot sequence. I've tried disabling pretty much everything in the BIOS to get it to boot, without success.

      Interestingly, OI boots fine (but does not recognise any network adapters).

      Does anybody have any ideas on what's going on?

      SunOS Release 5.11 Version 11.0 64-bit
      Copyright (c) 1983, 2011, Oracle and/or its affiliates. All rights reserved.
      x86_feature: lgpg
      x86_feature: tsc
      x86_feature: msr
      x86_feature: mtrr
      x86_feature: pge
      x86_feature: de
      x86_feature: cmov
      x86_feature: mmx
      x86_feature: mca
      x86_feature: pae
      x86_feature: cv8
      x86_feature: pat
      x86_feature: sep
      x86_feature: sse
      x86_feature: sse2
      x86_feature: htt
      x86_feature: asysc
      x86_feature: nx
      x86_feature: sse3
      x86_feature: cx16
      x86_feature: cmp
      x86_feature: tscp
      x86_feature: mwait
      x86_feature: cpuid
      x86_feature: ssse3
      x86_feature: sse4_1
      x86_feature: sse4_2
      x86_feature: 1gpg
      x86_feature: clfsh
      x86_feature: 64
      x86_feature: aes
      x86_feature: pclmulqdq
      x86_feature: xsave
      x86_feature: avx
      x86_feature: xsaveopt
      mem = 16734988K (0x3fd6c3000)
      Using default device instance data
      SMBIOS v2.6 loaded (10333 bytes)initialized model-specific module 'cpu_ms.GenuineIntel' on chip 0 core 0 strand 0
      root nexus = i86pc
      pseudo0 at root
      pseudo0 is /pseudo
      scsi_vhci0 at root
      scsi_vhci0 is /scsi_vhci
      npe0 at root: space 0 offset 0
      npe0 is /pci@0,0
      PCI Express-device: isa@1f, isa0
      pseudo-device: acpippm0
      acpippm0 is /pseudo/acpippm@0
      pseudo-device: ppm0
      ppm0 is /pseudo/ppm@0
      ramdisk0 at root
      ramdisk0 is /ramdisk
      root on /ramdisk:a fstype ufs
      acpinex0 at root
      acpinex: sb@0, acpinex1
      acpinex: socket@0, acpinex2
      acpinex: cpu@0, cpudrv0
      /fw/sb@0/socket@0/cpu@0 (cpudrv0) online
      pseudo-device: dld0
      dld0 is /pseudo/dld@0
      ISA-device: asy0
      asy0 is /pci@0,0/isa@1f/asy@1,3f8
      PCI Express-device: pci8086,1d1a@1c,5, pcieb6
      pcieb6 is /pci@0,0/pci8086,1d1a@1c,5
      PCI Express-device: pci8086,1d1e@1c,7, pcieb7
      pcieb7 is /pci@0,0/pci8086,1d1e@1c,7
      PCI Express-device: pci8086,244e@1e, pci_pci0
      pci_pci0 is /pci@0,0/pci8086,244e@1e
      PCI Express-device: pci8086,3596@1a, ehci0
      ehci0 is /pci@0,0/pci8086,3596@1a
      PCI Express-device: pci8086,3596@1d, ehci1
      ehci1 is /pci@0,0/pci8086,3596@1d
      cpu0: x86 (chipid 0x0 GenuineIntel 206D7 family 6 model 45 step 7 clock 1800 MHz)
      cpu0: Intel(r) Xeon(r) CPU E5-2603 0 @ 1.80GHz
      initialized cpu module 'cpu.generic' on chip 0 core 1 strand 0
      initialized model-specific module 'cpu_ms.GenuineIntel' on chip 0 core 1 strand 0

      panic[cpu1]/thread=ffffff001eabbc20: BAD TRAP: type=e (#pf Page fault) rp=ffffff001eabba10 addr=40 occurred in module "unix" due to a NULL pointer dereference

      #pf Page fault
      Bad kernel fault at addr=0x40
      pid=0, pc=0xfffffffffb80e213, sp=0xffffff001eabbb00, eflags=0x10086
      cr0: 8005003b<pg,wp,ne,et,ts,mp,pe> cr4: 406f8<osxsav,xmme,fxsr,pge,mce,pae,pse,de>
      cr2: 40cr3: f8e6000cr8: 0

      rdi: 0 rsi: 1 rdx: 2
      rcx: ffffff04dfc57440 r8: fffffffffb80e1f8 r9: ffffffffffffffff
      rax: ffffff04e5ca8a80 rbx: ffffff04e4a0a3c0 rbp: ffffff001eabbb30
      r10: fffffffffbd02930 r11: ffffff001eabbc20 r12: 0
      r13: 246 r14: 2 r15: 40
      fsb: 200000000 gsb: ffffff04e5ca8a80 ds: 38
      es: 38 fs: 0 gs: 0
      trp: e err: 0 rip: fffffffffb80e213
      cs: 30 rfl: 10086 rsp: ffffff001eabbb00
      ss: 38

      Warning - stack not written to the dump buffer
      ffffff001eabb930 unix:die+d8 ()
      ffffff001eabba00 unix:trap+152b ()
      ffffff001eabba10 unix:cmntrap+e6 ()
      ffffff001eabbb30 unix:cpupm_deferred_t_transition+1b ()
      ffffff001eabbb80 unix:cpu_idle_exit+10b ()
      ffffff001eabbbd0 unix:cpu_idle_mwait+139 ()
      ffffff001eabbc00 unix:idle+116 ()
      ffffff001eabbc10 unix:thread_start+8 ()

      syncing file systems... done
      skipping system dump - no dump device configured
      rebooting...

      Edited by: 935384 on 18-May-2012 15:21