6 Replies Latest reply: Jun 20, 2012 9:46 PM by user248025 RSS

    Error in searching AD Users

    847462
      Hi,

      I have successfully linked OBIEE 11.1.1.6 with Active Directory. I can login using AD users, I can also see the list of users in Admin Console.

      Problem occurs when I assign a report to a user, I'm unable to search for the user.

      Error shown:

      Error retrieving user/group data from Oracle BI Server's User Population API. Odbc driver returned an error (SQLExecDirectW). State: HY000. Code: 10058.
      *[NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred.*
      *[nQSError: 43113] Message returned from OBIS.*
      *SecurityService::assertUserWithLanguage [OBI-SEC-00018] Identity found 482321bbe4224aba97dcc6af340a3b84 but could not be asserted (HY000)*
      *SQL Issued: {call NQSGetGroupMemberships('GUID=482321bbe4224aba97dcc6af340a3b84')}*

      Has anyone encountered the same error?

      Thanks in advance.

      Regards,
      Kyk
        • 1. Re: Error in searching AD Users
          obiee_kid
          Try regenerating GUIDs:
          http://docs.oracle.com/cd/E21764_01/bi.1111/e10543/privileges.htm?#CHDEBGIA

          or remove old GUID references:

          http://docs.oracle.com/cd/E21764_01/bi.1111/e10543/privileges.htm?#BABJDCHE
          • 2. Re: Error in searching AD Users
            user248025
            Hi,

            After integrating with MSAD try to refresh GUID...

            for more refer below steps

            http://obieeelegant.blogspot.com/2012/01/obiee-11g-integration-with-ldap.html

            Thanks
            Deva
            • 3. Re: Error in searching AD Users
              847462
              Hi obiee_kid and Devarasu,

              I have tried regenerating the GUIDs but it did not solved the issue.

              After changing FMW_UPDATE_ROLE_AND_USER_REF_GUIDS to YES and adding <UpdateAccountGUIDs>UpdateAndExit</UpdateAccountGUIDs>, I restarted it using opmnctl but coreapplication_obips1 did not start.

              Processes in Instance: instance1
              --------------------------------------------------------------+---------
              ias-component | process-type | pid | status
              --------------------------------------------------------------+---------
              coreapplication_obiccs1 | OracleBIClusterCo~ | 4904 | Alive
              coreapplication_obisch1 | OracleBIScheduler~ | 6704 | Alive
              coreapplication_obijh1 | OracleBIJavaHostC~ | 2536 | Alive
              coreapplication_obips1 | OracleBIPresentat~ | N/A | Down
              coreapplication_obis1 | OracleBIServerCom~ | 8888 | Alive
              • 4. Re: Error in searching AD Users
                user248025
                Hi,

                1) Can you try to regenerate user GUIDs:

                Update the FMW_UPDATE_ROLE_AND_USER_REF_GUIDS parameter in NQSConfig.INI:
                Open NQSConfig.INI for editing at:
                ORACLE_INSTANCE/config/OracleBIServerComponent/coreapplication_obisn
                Locate the FMW_UPDATE_ROLE_AND_USER_REF_GUIDS parameter and set it to YES, as follows:
                FMW_UPDATE_ROLE_AND_USER_REF_GUIDS = YES;
                Save and close the file.
                Update the Catalog element in instanceconfig.xml:
                Open instanceconfig.xml for editing at:
                ORACLE_INSTANCE/config/OracleBIPresentationServicesComponent/
                coreapplication_obipsn
                Locate the Catalog element and update it as follows:
                <Catalog>
                <UpgradeAndExit>false</UpgradeAndExit>
                <UpdateAccountGUIDs>UpdateAndExit</UpdateAccountGUIDs>
                </Catalog>
                Save and close the file.
                Restart the Oracle Business Intelligence system components using opmnctl:
                cd ORACLE_HOME/admin/instancen/bin
                ./opmnctl stopall
                ./opmnctl startall
                Set the FMW_UPDATE_ROLE_AND_USER_REF_GUIDS parameter in NQSConfig.INI back to NO.
                Important: You must perform this step to ensure that your system is secure.
                Update the Catalog element in instanceconfig.xml to remove the UpdateAccount GUIDs entry.
                Restart the Oracle Business Intelligence system components again using opmnctl:
                cd ORACLE_HOME/admin/instancen/bin
                ./opmnctl stopall
                ./opmnctl startall

                For more ref:

                http://docs.oracle.com/cd/E23943_01/bi.1111/e10543/privileges.htm#CHDEBGIA

                http://obiee11gqna.blogspot.com/2011/10/obiee11g-updating-guids.html

                2) also you can try to restart it each component wise,

                obiee Drive path:\Oracle\Middleware\instances\instance1\bin>opmnctl startproc ias-component=co
                reapplication_obips1

                Thanks
                Deva
                • 5. Re: Error in searching AD Users
                  847462
                  Hi Deva,

                  After changing FMW_UPDATE_ROLE_AND_USER_REF_GUIDS to YES and adding <UpdateAccountGUIDs>UpdateAndExit</UpdateAccountGUIDs> then restarted it, one of the service did not start, as shown in my previous reply

                  Processes in Instance: instance1
                  --------------------------------------------------------------+---------
                  ias-component | process-type | pid | status
                  --------------------------------------------------------------+---------
                  coreapplication_obiccs1 | OracleBIClusterCo~ | 4904 | Alive
                  coreapplication_obisch1 | OracleBIScheduler~ | 6704 | Alive
                  coreapplication_obijh1 | OracleBIJavaHostC~ | 2536 | Alive
                  coreapplication_obips1 | OracleBIPresentat~ | N/A | Down
                  coreapplication_obis1 | OracleBIServerCom~ | 8888 | Alive

                  Is this normal?

                  Everything got back to "Alive" after setting it back to NO and removing UpdateAndExit. But still I got the same issue.
                  • 6. Re: Error in searching AD Users
                    user248025
                    Hi,

                    Check the sawlog01.txt and adminsever.log file find the latest log message and paste it here

                    did you try to start that bi presentation components alone? can try to re boot it and then try to start bi services and check it out.

                    Thanks
                    Deva