2 Replies Latest reply: May 27, 2012 11:09 PM by 940008 RSS

    Invalid RSA Modulus size error

    940008
      Hi All,

      I'm getting the Invalid RSA modulus size when i try and import certificates into a keystore. I have researched the problem and it mentions downloading the JCE unlimited strength files for it. I've done this and placed them in the security directory, replacing the other normal strength ones but no go. I have then restarted the server but to no avail.

      The error appears when i use the list or import commands: keytool -list -keystore cacerts

      We are using Java JRE1.4.2 and the certs we are importing are 2048bits.

      Thanks in advance.

      JM
        • 1. Re: Invalid RSA Modulus size error
          EJP
          Have you installed the unlimited-strength jars into both the JDK and the JRE?
          • 2. Re: Invalid RSA Modulus size error
            940008
            Thanks for responding EJP but it seems the upgrade we did to the piece of software either corrupted or did something strange to the cacerts file. We found a copy of the same file from before the upgrade, copied it over the current one and hey presto, everything started working as normal....Not sure what was wrong as we've done the upgrade a few times in our testing environments and we've never seen it before.

            I originally copied the unlimited strength files into the JRE but didn't think to put it in the JDK. Not sure if the JDK is installed.