This discussion is archived
1 Reply Latest reply: May 29, 2012 1:20 AM by gimbal2 RSS

How to update Mojarra to version 2.1.8

user10484841 Newbie
Currently Being Moderated
I want to update my JSF application to JSF version 2.1.8. I added these lines into the POM file of the WAR package:

<dependency>
<groupId>org.glassfish</groupId>
<artifactId>javax.faces</artifactId>
<version>2.1.8</version>
</dependency>

I also added the JSF repository. I package is build successfully with the JSF version 2.1.8. But when I open the Glassfish log I see that there is a version 2.1.6 deployed. What am I missing? Do I need to make some configuration into the Glassfish server?
  • 1. Re: How to update Mojarra to version 2.1.8
    gimbal2 Guru
    Currently Being Moderated
    user10484841 wrote:
    But when I open the Glassfish log I see that there is a version 2.1.6 deployed. What am I missing? Do I need to make some configuration into the Glassfish server?
    Shouldn't have to be, you should be able to deploy the JSF jars within your war and for your application that release of JSF is used. Either:

    - you didn't setup the dependencies in your poms properly such that maven package includes the jars in your war module
    - you are reading the logs wrong
    - you should be reading the glassfish documentation to see how to properly override the JSF implementation, or upgrading the one that is packaged with Glassfish itself

    Note that you shouldn't be needing any "JSF repository" - JSF is in Maven central.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points