This discussion is archived
4 Replies Latest reply: Jun 6, 2012 8:33 PM by 941852 RSS

Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQL

941852 Newbie
Currently Being Moderated
Hi All,

I got this error from weblogic log file.

It happens when config the datasource with the "Test Connections On Reserve" is enabled. The application runs without any error.

My Connection pool is configed as following:

database is SQLServer;
driver is net.sourceforge.jtds.jdbc.Driver;
Initial Capacity: 3
Maximum Capacity:15
Capacity Increment:1

Test Table Name: SQL SELECT 1(or put any table that exists in the database , same error)


Does anybody encount this error before or anyone can help about this, thanks a lot.
  • 1. Re: Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQL
    vladodias Guru
    Currently Being Moderated
    Hi,

    If you post the complete stack trace we can have a look.

    Cheers,
    Vlad
  • 2. Re: Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQL
    941852 Newbie
    Currently Being Moderated
    Hi Vlad,

    Thanks for your reply, but there is no other information, only repeatly show this error message in the weblogic file.

    <6/06/2012 01:48:09 PM EST> <Error> <JDBC> <BEA-001112> <Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQLException: I/O Error: Connection reset".>
    <6/06/2012 01:50:09 PM EST> <Error> <JDBC> <BEA-001112> <Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQLException: I/O Error: Connection reset".>
    <6/06/2012 01:52:09 PM EST> <Error> <JDBC> <BEA-001112> <Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQLException: I/O Error: Connection reset".>
    <6/06/2012 01:54:09 PM EST> <Error> <JDBC> <BEA-001112> <Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQLException: I/O Error: Connection reset".>
    <6/06/2012 01:56:09 PM EST> <Error> <JDBC> <BEA-001112> <Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQLException: I/O Error: Connection reset".>
    <6/06/2012 01:58:09 PM EST> <Error> <JDBC> <BEA-001112> <Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQLException: I/O Error: Connection reset".>
    <6/06/2012 02:00:09 PM EST> <Error> <JDBC> <BEA-001112> <Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQLException: I/O Error: Connection reset".>
    <6/06/2012 02:02:09 PM EST> <Error> <JDBC> <BEA-001112> <Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQLException: I/O Error: Connection reset".>
    <6/06/2012 02:04:09 PM EST> <Error> <JDBC> <BEA-001112> <Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQLException: I/O Error: Connection reset".>
    <6/06/2012 02:06:09 PM EST> <Error> <JDBC> <BEA-001112> <Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQLException: I/O Error: Connection reset".>



    Is there other information that I can provide to you that you need,thanks.
  • 3. Re: Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQL
    vladodias Guru
    Currently Being Moderated
    Hi,

    I do have a SQLServer data source in my environment, it is working fine and has "Test Connections On Reserved" checked and the same "SQL SELECT 1" as you do.

    But, the driver that I'm using is: weblogic.jdbc.sqlserver.SQLServerDriver
    938849 wrote:
    The application runs without any error.
    Is the application actually using this data source?

    Cheers,
    Vlad

    Give points - it is good etiquette to reward an answerer points (5 - helpful; 10 - correct) for their post if they answer your question. If you think this answer is helpful, please consider giving points.
  • 4. Re: Test "SELECT 1" set up for pool "UAT" failed with exception: "java.sql.SQL
    941852 Newbie
    Currently Being Moderated
    Hi Vlad,

    The same setting and same driver using in another application, it works very well, but this application does not.



    Also the application use the same datasource configured in the xml file:      
    <bean id="dataSource" class="org.springframework.jndi.JndiObjectFactoryBean">
              <property name="jndiName" value="java:comp/env/jdbc/datasource-acu-pool"/>                                                                 
         </bean>

    The JNDI name in the weblogic is "jdbc/datasource-acu-pool", this make sure the application use this datasource and the application also works without any error.




    It is really strange.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points