0 Replies Latest reply on Jun 8, 2012 1:43 AM by user585822-Oracle

    JDK 1.6 SLES-10 Linux 64 - Unable to create thread dump

      I am trying to debug some JDBC related issues and need to create a thread dump.
      This is a 2 node system:
      DB - on one node
      Applications on another (JVM)

      Whenever we run any of the following:
      kill -3
      kill -QUIT
      kill -9
      there is no thread dump created on the applications tier JVM stdout/stderr locations.
      On all other servers that I have tested the thread dump is created.

      So I decided to use jstack. When I run jstack I get:

      Attaching to process ID 10788, please wait...
      sun.jvm.hotspot.debugger.NoSuchSymbolException: Could not find symbol "gHotSpotVMTypeEntryTypeNameOffset" in any of the known library names (libjvm.so, libjvm_g.so, gamma_g)
      at sun.jvm.hotspot.HotSpotTypeDataBase.lookupInProcess(HotSpotTypeDataBase.java:400)
      at sun.jvm.hotspot.HotSpotTypeDataBase.getLongValueFromProcess(HotSpotTypeDataBase.java:381)
      at sun.jvm.hotspot.HotSpotTypeDataBase.readVMTypes(HotSpotTypeDataBase.java:86)
      at sun.jvm.hotspot.HotSpotTypeDataBase.<init>(HotSpotTypeDataBase.java:68)
      at sun.jvm.hotspot.bugspot.BugSpotAgent.setupVM(BugSpotAgent.java:550)
      at sun.jvm.hotspot.bugspot.BugSpotAgent.go(BugSpotAgent.java:476)
      at sun.jvm.hotspot.bugspot.BugSpotAgent.attach(BugSpotAgent.java:314)
      at sun.jvm.hotspot.tools.Tool.start(Tool.java:146)
      at sun.jvm.hotspot.tools.JStack.main(JStack.java:58)
      Debugger attached successfully.
      jstack requires a java VM process/core!

      I couldnt find package package java-1.6.0-openjdk-debuginfo for SLES so we installed the one for redhat
      It installed but we still get the message when running jstack and no thread dump

      Any ideas?