This discussion is archived
2 Replies Latest reply: Jun 13, 2012 5:20 AM by 943101 RSS

Authentication fields are not enabled in connection manager

943101 Newbie
Currently Being Moderated
We have installed Oracle 11.2.0 which is *64-bit* software in Windows 2008 R2 Operating system(*64-bit*)
so we are able to log-in through SQL plus client& no problem with any TNS entry issues.
We have requirement use this Oracle database with MS SQL analysis services.
So We have installed SQL server Business Intelligence 2012 which is also *64-bit* Software.

Here is the issue: When we open MS SQL server Management studio
In Databases --> Data Sources--> Connection Manager-->
we found Authentication fields are not enabled under Native OLE DB\Oracle Provider for OLE DB driver.
and when we process cubes, we are getting following error:
error1)- Errors in the back-end database access module. The provider 'OraOLEDB.Oracle.1' is not registered.
error2)- The following system error occurred: Class not registered.

Please help me regarding this issue..

Thanks in Advance!!
Dharani
  • 1. Re: Authentication fields are not enabled in connection manager
    gdarling - oracle Expert
    Currently Being Moderated
    I'm not familiar with SSMS 2012, but in the past the tool was always 32 bit. Are you sure SSMS is 64 bit?

    The error you're getting almost always results from having the wrong bitness of Oracle client installed. (There's an issue in 11203 where the provider didn't get registered during client install, but 11202 doesn't have that issue).

    I'd start by testing some vbscript using the x64 oledb provider to at least try to confirm the install is good.

    1) Place the following code in a text file with a .vbs extension. (c:\testoledbcon.vbs for example)
    set con = createobject("adodb.connection")
    con.open "provider=oraoledb.oracle;user id=scott;password=tiger;data source=orcl"
    set rs = createobject("adodb.recordset")
    rs.open "select user || ' connected at ' || to_char(sysdate) from dual",con
    wscript.echo rs.fields(0).value
    rs.close
    set rs=nothing
    con.close
    set con=nothing
    2) Change the connect string (line 2) as appropriate to reflect a user id, password, and tnsnames alias appropriate for your environment

    3) run it at a cmd prompt by typing cscript.exe testoledbcon.vbs

    Greg
  • 2. Re: Authentication fields are not enabled in connection manager
    943101 Newbie
    Currently Being Moderated
    Thanks for your reply Greg :)

    I have run .vbs file with your code in two of my servers.. I got reply like below in command prompt for those 2 servers.

    Server1----------------------->
    Microsoft (R) Windows Script Host Version 5.8
    Copyright (C) Microsoft Corporation. All rights reserved.

    <scott> connected at 2012-06-13 11:33:16
    -------------------------------------------
    Error when I am processing cube in SSMS 2012 for Server1
    1> OLE DB error: OLE DB or ODBC error: ORA-12154: TNS:could not resolve the connect identifier specified.
    2> Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of '<DataSourceName>', Name of '<DataSourceName>'.

    Server2------------------------->
    C:\Users\ldhara\Desktop>cscript testoledbcon.vbs
    Microsoft (R) Windows Script Host Version 5.8
    Copyright (C) Microsoft Corporation. All rights reserved.

    C:\Users\ldhara\Desktop\testoledbcon.vbs(2, 1) <orcl>.Connection: Provider cannot be found. It may not be properly installed.
    ------------------------------------------
    Errors when I am processing cube in SSMS 2012 for Server2
    1> Errors in the back-end database access module. The provider 'OraOLEDB.Oracle.1' is not registered.
    2> The following system error occurred: Class not registered
    3> Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of '<DataSourceName>', Name of '<DataSourceName>'.

    But in either of the servers Connection manager Authentication(username, password) fields are not enabled to check for TestConnection. when I am clicking on Test connection button in connection manager I getting following error in new pop-up window:
    Test connection failed because of an error in initializing provider.The 'OraOLEDB.Oracle.1' provider is not registered on local machine
    Thanks in advance..

    Regards,
    Dharani

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points