This discussion is archived
1 Reply Latest reply: Jul 20, 2012 9:44 AM by 943324 RSS

Solaris 8 ufsrestore issues

943211 Newbie
Currently Being Moderated
Hello all,
this is my first post here.
I am experiencing a strange issue when attempting to do a ufsrestore of an entire backed up OS (Sol 8) The restore goes fine but some time after the new server is up and running I start getting these errors;

# Jun 13 01:20:00 usmlsu52new.arrow.com cron[23056]: open_module: stat(/usr/lib/security/pam_projects.so.1) failed: No such file or directory
Jun 13 01:20:00 usmlsu52new.arrow.com cron[23056]: load_modules: can not open module /usr/lib/security/pam_projects.so.1

# ls | more
ls: Cannot find /usr/lib/ld.so.1
more: Cannot find /usr/lib/ld.so.1
Killed
#
# Jun 13 01:20:00 usmlsu51new.arrow.com cron[2638]: open_module: stat(/usr/lib/security/pam_projects.so.1) failed: No such file or directory
Jun 13 01:20:00 usmlsu51new.arrow.com cron[2638]: load_modules: can not open module /usr/lib/security/pam_projects.so.1


I now can't do anything on the server? I am at the root prompt but when I try to run a ls, df -k, cp it just gives me the same error complaining about the ld.so.1 file missing??

Can anyone help me with this

Thanks
Paul.
  • 1. Re: Solaris 8 ufsrestore issues
    943324 Newbie
    Currently Being Moderated
    Could be the library file is missing or corrupted. Need to copy the good version of the library file.

    Since, the system is up, the recovery steps are as follows:
    1) /usr/sbin/static/mv /usr/lib/ld.so.1 /usr/lib/ld.so.1.buggy
    2) /usr/sbin/static/cp /etc/lib/ld.so.1 /usr/lib
    It worked for me on Solaris 9 and Solaris 10.


    In case, the server doesn't boot, need to boot of media, mount the root file system and /usr, if /usr is a separate filesystem and perform the above commands.

    -Siddi

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points