1 Reply Latest reply: Mar 8, 2013 10:06 AM by Krewat RSS

    sudo-1.8.3p2-sol10-x86 error with libc.so.1

    943559
      I installed sudo and I get this error when I run sudo

      #sudo
      ld.so.1: sudo: fatal: libc.so.1: version `SUNW_1.22.7' not found (required by file /usr/local/bin/sudo)
      ld.so.1: sudo: fatal: libc.so.1: open failed: No such file or directory
      Killed

      I ran ldd on sudo and I got this.

      #ldd /usr/local/bin/sudo
      libiconv.so.2 => /usr/local/lib/libiconv.so.2
      libsec.so.1 => /usr/lib/libsec.so.1
      libc.so.1 => /usr/lib/libc.so.1
      libc.so.1 (SUNW_1.22.7) =>       (version not found)
      libsocket.so.1 => /usr/lib/libsocket.so.1
      libgcc_s.so.1 => /usr/local/lib/libgcc_s.so.1
      libnsl.so.1 => /usr/lib/libnsl.so.1
      libavl.so.1 => /lib/libavl.so.1
      libmp.so.2 => /lib/libmp.so.2
      libmd.so.1 => /lib/libmd.so.1
      libscf.so.1 => /lib/libscf.so.1
      libdoor.so.1 => /lib/libdoor.so.1
      libuutil.so.1 => /lib/libuutil.so.1
      libgen.so.1 => /lib/libgen.so.1
      libm.so.2 => /lib/libm.so.2

      What am I missing here. I was wondering how to fix this.

      Edited by: 940556 on Jun 13, 2012 2:40 PM
        • 1. Re: sudo-1.8.3p2-sol10-x86 error with libc.so.1
          Krewat
          It means that the sudo package you have was compiled with a later version of libc. Sun at some point started to distribute versions of libc with specific kernel packages, IIRC.

          I just had the same exact thing, same version of sudo - I assume you got it from sunfreeware.com?

          Installing the latest recommended Solaris patches fixed the problem. Good luck ;)

          Edited by: 888316 on Mar 8, 2013 8:06 AM