5 Replies Latest reply: Jun 14, 2012 2:47 PM by thejame RSS

    Security features not working as expected

    864099
      Hi Every one,

      I have integrated ms active directory and able to login with those user names and passwords

      but in the object level security. when I deny permissions for some subject areas to some of the users. it is not working they can see all subject areas.

      please help me in this regard
        • 1. Re: Security features not working as expected
          user248025
          Hi,

          Which version are u using?


          We too faced the same issues few months before, it's really very Strange Security Issues in Obiee11g

          FYI, in obiee11g(11.1.1.5.0) version we have faced Application role name issue (It should be only character) if your keeping like below then the application role is not working properly as we expect permission setup.

          So Please don’t keep the role like 01_Manager,02_Stusent,-,#,numbers etc.
          Due to this issues affected our catalog object level permission

          Thanks
          Deva
          • 2. Re: Security features not working as expected
            864099
            Hi Devarasu,

            I am using obiee 11.1.1.6 and have applied all patches.

            for other obejcts security is working fine.

            It is not working only for subject areas.
            • 3. Re: Security features not working as expected
              thejame
              In the Presentation Services, under "Administration" - "Manage Privileges" do you have access to the subject area denied for these users/groups/roles?
              That will make sure they don't see it in Answers.

              If you deny access in the Repository they might get to the subject area but shouldn't get any data back.
              • 4. Re: Security features not working as expected
                864099
                HI,

                Yes I have denied acces to a users for the subject area in the presentation services, manage privilages.

                but still they can see that subject area and fetch data from them
                • 5. Re: Security features not working as expected
                  thejame
                  We had this issue in 11.1.1.5 but haven't had the problem come up in 11.1.1.6.1 (not to say that it could though, which is very scary actually).

                  The proposed solution was to install Patch 12830486 OCT 2011 CPU - UPDATE FOR OBIEE 11.1.1.5.0
                  I was pointed to look at this:
                  Where To Find OBIEE 10g and 11g Critical Patch Updates (CPU) Patches And/Or Security Alerts (Doc ID 1297349.1)

                  I would open an SR with Oracle right away, and try to capture the problem happening as much as you can (it was hard to "prove" the error with them for us).
                  That patch helped our issue though.

                  (This might be included in Bundle Patch 1 or Bundle Patch 2, which I would definitely try patching on your system if you meet the requirements)