This discussion is archived
3 Replies Latest reply: Jul 9, 2012 11:05 AM by 904871 RSS

Web Start Application fails after upgrade to JRE 1.6.0_u33

820681 Newbie
Currently Being Moderated
I have a production application that uses java web start for deployment. All has gone well, but we are experiencing problems when testing upgrading to the latest JRE update 1.6.0_u33.

The application is composed of several jar files, all of which are signed with a code signing certificate. However, after updating the JRE, I receive the error :

#### Java Web Start Error:
#### Unsigned application requesting unrestricted access to system
Unsigned resource: the first jar file in my jnlp

This is a pretty odd error, since the jar is definitely signed. I can find it in the webstart cache and run jarsigner -verify against it and it verifies successfully.

If I remove the application and reinstall it, everything works fine, but this is a pretty unacceptable solution for thousands of users, many of which are not very technical.

Does anyone have any solutions or has anyone encountered the same problem? It is currently a showstopper for us to taking this new JRE update which contains some critical security updates we would like to have implemented.

Thanks in advance for any help.
  • 1. Re: Web Start Application fails after upgrade to JRE 1.6.0_u33
    817614 Explorer
    Currently Being Moderated
    It is a known issue: http://java.com/en/download/help/clearcache_upgrade.xml.
  • 2. Re: Web Start Application fails after upgrade to JRE 1.6.0_u33
    945538 Newbie
    Currently Being Moderated
    I encountered the same issue once but since then it has worked for us on multiple machines. We had the same issue with u24 when the app failed to download. We tried the latest u33, which deleted the apps shortcut for some reason, but downloaded and ran the app successfully.

    Edited by: 942535 on 26/06/2012 20:47
  • 3. Re: Web Start Application fails after upgrade to JRE 1.6.0_u33
    904871 Newbie
    Currently Being Moderated
    Hi

    I have seen this post a little bit late, but... We have also encountered such issue.
    There is another workaround than ask people to empty the java web start cache.
    In order to force the end user's computer to download again you application entirely, we have signed again ALL the jar files and uploaded them to our server.
    That works well but... if somebody download the "new" files and upgrades java to 1.6_0_33 afterwards... same issue will appear again.


    Please observe that the traffic in this forum has started to decrease strongly. That's not amazing when you see that you cannot count on this product.
    Java web start has never worked correctly and that for a long time. This one suffers of numerous bugs and regressions. We should rather call it Java Nightmare Neverstart
    It's a shame.

    Sun has been acquired by Oracle but that does not seem change anything.

    Java RIP

    Claude

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points