This discussion is archived
4 Replies Latest reply: Aug 14, 2012 6:42 PM by brettr RSS

URL rewrite

Cheney Shue Newbie
Currently Being Moderated
Hi,
I deployed Endeca Studio to Weblogic. The url of Studio is http://192.168.0.3:7001/. I installed Apache HTTP Server on 80 port to rewrite URLs of all applications. So that I can access Endeca via http://servername/endeca.

The first step is successful. Apache can rewrite to http://192.168.0.3:7001, while I visit http://servername/endeca. But, Endeca turn to http://192.168.0.3:7001/web/guest/home after login. How let Endeca use relative url "/web/guest/home" instead of absolute url "http://192.168.0.3:7001/web/guest/home".

Thanks
  • 1. Re: URL rewrite
    Sasha Newbie
    Currently Being Moderated
    When you deploy Studio behind a web server, you need to configure it to be aware of the web server information. If you haven't already done this, you'll need to modify your portal-ext.properties file to set these values with the appropriate information for your apache server:

    ##
    ## Web Server
    ##
    #
    # Set the HTTP and HTTPs ports when running the portal in a J2EE server that
    # is sitting behind another web server like Apache. Set the values to -1 if
    # the portal is not running behind another web server like Apache.
    #
    web.server.http.port=80
    web.server.https.port=443
    #
    # Set the hostname that will be used when the portlet generates URLs.
    # Leaving this blank will mean the host is derived from the servlet
    # container.
    #
    web.server.host=apache.host.com
    #
    # Set the preferred protocol.
    #
    web.server.protocol=https
  • 2. Re: URL rewrite
    Cheney Shue Newbie
    Currently Being Moderated
    Thank you. It works.
  • 3. Re: URL rewrite
    955816 Newbie
    Currently Being Moderated
    Hi

    Thank you for the solution,.

    In my case, endeca address "http://192.168.0.1:8080/" is connected throuh my apache server "http://myserver/endeca" based on the solution provided. Its working fine. But, when accessing the direct URL, the portlets are not loaded properly. Its working only through apache http server URL.

    Any configuration change required for this to work in both URL's "

    Thanks in Advance,.
  • 4. Re: URL rewrite
    brettr Journeyer
    Currently Being Moderated
    Hi,

    You don't mention why you need to access the portal server directly versus via the HTTP server.

    Mixing a ROOT context path with a non-root path on the appserver is a more complex setup. You'd need to provide your mod_jk or mod_proxy configuration, and the portal settings for web.server.* mentioned above, as well as the value of portal.ctx.

    Best
    Brett

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points