This discussion is archived
1 Reply Latest reply: Jun 20, 2012 11:20 AM by 944853 RSS

recreate pool problem on a 7110 Sun Storage

944853 Newbie
Currently Being Moderated
Hi,

we have a Sun 7110 that runs mostly well, except when the iscsi volume fills up, the volume stop, and we have to drop it and recreate it. 3 weeks ago, to counter that, I switched on dedup and compression. No idea if it is a good or bad idea, but because we got lots of i/o hanging on the volume :
- we tried to drop again the volume via the web interface.
- after destroying it, impossible to recreate it, so we switch to the shell to see what's going on. In fact all space was filled up into the "zombie" share (pool-0/???/zombie). No idea what it is, because we never got snapshots. And the cpu was still in the roof like it was still compressing, deduplicating or what...
- we decided to connect to destroy the whole pool (with difficulty), and the CPU stop working as crazy

Now impossible to recreate it via the web interface.
- i can create the pool with zpool and create volume with zfs but they don't show up in the interface
- if we destroy again and try to create it in the web interface, we have of course no pool in the "Available pool", so I try to create it BUT i can't:
Model     Sun Storage 7110
Data Devices     -
Log Devices     -
Cache Devices     -

as is there weren't any disks!
I checked : the disks are ok from the OS point of view (/var/ak/logs/debug.sys doesn't complain for example, except for a spare disk that I labeled back)

Any idea how to "reset" the storage pool?
Do I must go through the "factory reset" (I'm not even sure it can help).
Or should I forgot Sun/oracle appliance kit, and install freenas instead? :-)

Any help will be appreciate (or similar concerns :-) )


Nicolas Zin

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points