This discussion is archived
13 Replies Latest reply: Nov 1, 2012 7:41 PM by user157995 RSS

local storage on DL380G7 using OVM 3.1.1

945859 Newbie
Currently Being Moderated
Hi,

I am having problems using my local disks on a HP DL380G7 server with OVM version 3.1.1
Using OVM 3.0.3 on a similar server there is no problem using the local disks.
They both have a HP Smart Array P410i controller and 600gb SAS disks.
In both situations I have two arrays, one for OVM and the other for a repository. No filesystems are present on the one used for the repository.

On OVM 3.0.3 I can see the disk with "multipath -ll" and it is present in /dev/mapper. The devices are /dev/sd[a-b]
On OVM 3.1.1 I can't see the disk with "multipath -ll" it is not present in /dev/mapper and the devices are /dev/cciss/c0d[0-1]
As fas as I know I have no influence in how the devices are named, this is part of the OS and the drivers used.

I also tried "Blacklisting of System Disks for Multipathing Fails on HP Smart Array (CCISS) Disk Devices (http://docs.oracle.com/cd/E26996_01/E18546/E18546.pdf), but no luck.
I did see the "SAS Disks Only Supported in Shared Configuration (SAS SAN)" (http://docs.oracle.com/cd/E27300_01/E27307/E27307.pdf) but i'm not sure if that is a "temorary" bug, or if they will not support local disks anymore.
That would mean I can't update my 3.0.3 version and keep my local storage repository.

I hope someone can help me out, or at least confirm they have deliberately removed functionality.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points