2 Replies Latest reply on Jun 30, 2012 10:56 AM by Udo

    APEX Listener with APEX 3.0 on 11gR2

    Rob
      Yes, I am crazy.

      We have many many APEX applications in APEX 3.0 running on a 10.2.0.4 database that needs desperately to be upgraded. As a test, I've set up a clean 11gR2 database and copied the production APEX database into it via datapump. I set up APEX Listener, as I don't have any OAS sitting around and the EPG doesn't seem to be supported for APEX 3.0... the Listener doesn't say one way or the other.

      When trying to log in, I get the login page, but it tries to reference files such as apex_get_3_1.js while I only have files such as htmldb_get.js in my images directory in production. I noticed it is looking for what appears to be 3.1 files instead of 3.0 files... which concerns me.

      The APEX listener appears to be more than just a Java PL/SQL gateway.

      Is there a minimum version of APEX the APEX Listener supports?

      Interested in pointers!

      Rob
        • 1. Re: APEX Listener with APEX 3.0 on 11gR2
          Prabodh
          Hi Rob,

          >
          We have many many APEX applications in APEX 3.0 running on a 10.2.0.4 database that needs desperately to be upgraded. As a test, I've set up a clean 11gR2 database and copied the production APEX database into it via datapump. I set up APEX Listener, as I don't have any OAS sitting around and the EPG doesn't seem to be supported for APEX 3.0... the Listener doesn't say one way or the other.
          >
          From what I remember Apex 3.0.x did support EPG. Which Apex version have you installed on 11gR2? Did you remove the Apex that comes with 11g and install Apex 3.0? Or are you trying to run 3.0 applications on 3.2 or 4.x ?

          >
          When trying to log in, I get the login page, but it tries to reference files such as apex_get_3_1.js while I only have files such as htmldb_get.js in my images directory in production. I noticed it is looking for what appears to be 3.1 files instead of 3.0 files... which concerns me.
          >

          ApexListener does not use the JS and other files in the /i/ folders. I think you have a newer Apex installed on 11gR2, and that is the reason you see these errors. If you have installed a newer version of Apex then you will need to upgrade your application to the current version.
          You will have to do the upgrade irrespective of whether you use ApexListener, OHS or EPG , if you are trying to deploy them in a newer version.

          >
          The APEX listener appears to be more than just a Java PL/SQL gateway.

          Is there a minimum version of APEX the APEX Listener supports?

          >
          There is no minimum version of Apex, but there is a minimum Database version. Of course, 11g is supported.

          Regards
          • 2. Re: APEX Listener with APEX 3.0 on 11gR2
            Udo
            Hi Rob,
            Yes, I am crazy.
            Why would that be? ;)
            We have many many APEX applications in APEX 3.0 running on a 10.2.0.4 database that needs desperately to be upgraded. As a test, I've set up a clean 11gR2 database and copied the production APEX database into it via datapump. I set up APEX Listener, as I don't have any OAS sitting around and the EPG doesn't seem to be supported for APEX 3.0... the Listener doesn't say one way or the other.
            APEX 3.0 is supprted by EPG. See the [url http://docs.oracle.com/cd/B32472_01/doc/install.300/b32468/post_inst.htm#CHDBEJDA]APEX 3.0 Installation Guide for details.
            APEX Listener is capable of hosting APEX 3.0 as well, though APEX 3.0 wasn't supported anymore when APEX Listener was initially released. The current APEX release at that time was 4.0, so this would be the first version to be known as really stable, whereas you won't get any support for older releases anymore. From personal experience I know that there are now issues with APEX 3.1 and APEX Listener, so it'll probably also work with 3.0.
            Concerning your database release, the minimum for APEX Listener is 10.2.0.3, so you're definetly safe on that part, though I'd recommend to upgrade as regular support for 10.2 databases ended.
            When trying to log in, I get the login page, but it tries to reference files such as apex_get_3_1.js while I only have files such as htmldb_get.js in my images directory in production. I noticed it is looking for what appears to be 3.1 files instead of 3.0 files... which concerns me.
            This indicates that your APEX would actually be a 3.1 and you should update you images directory.
            The APEX listener appears to be more than just a Java PL/SQL gateway.
            It is, but this has nothing to do with your 3.1 JS files, if this is why you stated this.
            Is there a minimum version of APEX the APEX Listener supports?
            As mentioned above, 4.0 would be a safe approach, but 3.1 will definetly work, 3.0 probably will as well. I'd recommend you find out which APEX version is actually installed on your database before you consider any upgrade operations. Run the following query as privileged user:
            SELECT comp_name, version, status
              FROM dba_registry
             WHERE comp_id = 'APEX';
            -Udo