0 Replies Latest reply: Jul 2, 2012 10:04 AM by 929890 RSS

    Calling Java Stored Procedure failed SQLXML

    929890
      I tried to upload a simple class to Oracle in which I want to use java.sql.SQLXML class using:
      loadjava -u user/passwd@host:1521:xyz -v -resolve C:\develop\workspaces\Test\src\lbb\apc\test\JavaStoredProcedureTest.java
      loadjava answers with:
      creating : source lbb/apc/test/JavaStoredProcedureTest
      loading  : source lbb/apc/test/JavaStoredProcedureTest
      resolving: source lbb/apc/test/JavaStoredProcedureTest
      errors   : source lbb/apc/test/JavaStoredProcedureTest
          ORA-29535: Quelle erfordert Neukompilierung
          lbb/apc/test/JavaStoredProcedureTest:6: cannot find symbol
          symbol  : class SQLXML
          location: package java.sql
          import java.sql.SQLXML;
      Then I found that the Oracle JDBC driver does not support the SQLXML type, thus changing my program to use XMLType:
      XMLType sqlXml = (XMLType)rs.getSQLXML(1);
      but it doesn't help as well as it doesn't help to use
      Clob clob = rs.getClob(1);
      Finally I tried (and failed) to use
      Object obj = rs.getObject(1);
      
      results in:
      
      java.sql.SQLException: ORA-29532:Java call terminated by uncaught Java exception:
      What can I do to solve this problem?