4 Replies Latest reply on Jul 3, 2012 1:02 PM by Pascal B

    Changes in JavaFiles dismissed by deployment

    Pascal B
      Hello Community. I just ran into a really confusing problem. For some reason none of my changes to any of my javabeans are being noted. This means, no matter how much I change in my javaBeans, the deployed application still runs with the files from about 2 hours ago. So if I had a button bound to a certain method and i deleted the entire body of this method and replaced it with a simple "System.out.print("Hello World");" it still performed the actions and tasks that were in this method before the changes.

      Here is what I tried:
      restart jdev
      restart and reset the iOS simulated device
      remove and open the application inside of jdev
      deleted the javaBean files from my harddrive (or moved them to a random location) and deployed (still worked)

      I am sort of baffled by this, does jdev have some sort of cache where it saves my java files? Is there a way to flush this cache, so I can continue working?
      Kind regards,
        • 1. Re: Changes in JavaFiles dismissed by deployment
          Denis T-Oracle
          Make sure you delete the application from your device/simulator. Have you by chance changed the application bundle id? That would certainly give you this error.

          Start by removing the app from the simulator then do a clean-all of your project and redeploy. If the condition persists there is definitely some other issue occurring. If you can, try it on another machine.
          • 2. Re: Changes in JavaFiles dismissed by deployment
            Pascal B
            Alright, I removed the app from the iOS device, but that didnt help. Then I removed the application from jdeveloper, moved the application sources to a different directory and renamed it, then reimported, now everything works again. Thanks!
            • 3. Re: Changes in JavaFiles dismissed by deployment
              Pascal B
              I just installed jdev on a second machine to access a test web-service and now I get the same problem as before, however my previous solution doesn't work anymore. I just copied all the project files over there and now I get the same problem (jdev deploys old versions of my java files with methods lacking that i implemented recently). There must be some sort of cache where it gets those from otherwise I cant explain why it deploys old versions of my files.
              • 4. Re: Changes in JavaFiles dismissed by deployment
                Pascal B
                Again, problem has been solved. This time by doing the following:

                Found the java file in question via finder.
                opened it with textedit, copied all the code,
                deleted it, created a new file, pasted the code from before
                saved this file and renamed it to match the previous name

                I have two suspicions: either it has something to do with the versioned file format mac is using [(see Here)|http://www.maclife.com/article/howtos/how_use_versioning_control_mac_os_x_lion]
                or with some other form of saving and caching mechanism in jdeveloper, however I don't know of any.

                By the way, I deleted my entire system11. folder, so all my settings were reset, yet the problem still persisted. Maybe this helps any of those who intend to try to resolve this issue.