5 Replies Latest reply: Aug 16, 2013 4:22 AM by 972484 RSS

    Accept Production Deployment  is not displaying in the workflow

    921570
      Hi,

      I have deployed 1 project into production, it was a scheduled deployment but the final step Accept Production Deployment is not available, the project history

      showing completed but the project is still in the active list. because of this issue we are not able to modify the asset as the modified asset is not displaying in the

      repository.

      The project is in the locked and editable is false state,and final state in the history is showing as below

      Author:
      Date: Jul 2, 2012 12:10 AM
      Action: system

      Deployment 459065 to Target Production completed successfully.
        • 1. Re: Accept Production Deployment  is not displaying in the workflow
          Praveer.Rai
          Try below :

          Go to Content Administration >> Admin Console >> Overview >> Production.

          Here in one of the Tabs you will find what you require , Don't remember exactly i think it will be one of these tabs : To do/Plan/Project.


          ~ Praveer
          • 2. Re: Accept Production Deployment  is not displaying in the workflow
            945521
            Hi,

            Navigate through Content Administration >Admin Console > Overview >Production(Name of the Site) >Projects in BCC.

            Click on the Project name whose status is Active you will be redirected to Project detail Page where you can complete the action "Accept Production Deployment".
            • 3. Re: Accept Production Deployment  is not displaying in the workflow
              srikanthsonti
              Hi,

              Can you also check the workflow definition that you are using for the scheduled deployment? You can verify this using ATG ACC and check if the accept production deployment step is there in the workflow and that there are no errors in the workflow definition.
              • 4. Re: Accept Production Deployment  is not displaying in the workflow
                dominiclovell
                Check there isnt a hung/error project in the admin console. If there is fix it.

                Otherwise, worse case scenario.

                Otherwise use the delete-process.jsp (you need to look up the epub_process table for the process ID).

                <% @page import = "atg.epub.project.*" %> <% @page import = "atg.dtm.*" %> <% @page import = "atg.nucleus.*" %> <% @page import = "javax.transaction.*" %> < link href = "style.css"
                type = "text/css"
                rel = "stylesheet" / > < div style = "padding: 5px;" > <% boolean rollback = true;
                TransactionManager tm = (TransactionManager) Nucleus.getGlobalNucleus().resolveName("/atg/dynamo/transaction/TransactionManager");
                TransactionDemarcation td = new TransactionDemarcation();
                try {
                td.begin(tm);
                atg.deployment.server.SecurityManager.becomeTheSuperDood();
                ProcessHome processHome = ((ProcessHome) ProjectConstants.getPersistentHomes().getProcessHome());
                String processId = request.getParameter("process_id");
                if (processId == null) {
                out.println("TRYING HYPNOSIS TO GUESS PROCESS ID..... FAILED. Try explicitly specifying a process_id request parameter. ");
                return;
                }
                atg.epub.project.Process process = processHome.findById(processId);
                if (process == null) {
                out.println("wrong process_id parameter; not such process");
                return;
                }
                Project project = process.getProject();
                if (project == null) {
                process.delete();
                rollback = false;
                out.println("Process was found but there was no project associated with it. Process was deleted successfully.");
                return;
                }
                project.delete("publishing");
                out.println("Process with id " + processId + " was found and deleted successfully."); %> < br / > < input type = "button"
                onclick = "window.close()"
                value = "Cancel/Close"
                style = "font-size: 10px; background-color: #C3593C; color: white;" / > <% rollback = false;
                } catch (Throwable t) {
                t.printStackTrace(System.out);
                out.println(t);
                } finally {
                atg.deployment.server.SecurityManager.becomeNOTTheSuperDood();
                try {
                if (td != null) td.end(rollback);
                } catch (TransactionDemarcationException e) {
                e.printStackTrace();
                }
                } %>
                • 5. Re: Accept Production Deployment  is not displaying in the workflow
                  972484


                  How did you solve dis problem.. plz let me knw..
                  m facing the same issue..