0 Replies Latest reply: Jul 4, 2012 4:28 PM by 947494 RSS

    Unable to launch application with java web start (OILOM)

    947494
      I'm connecting to a remote Oracle console from a server, using "oracle integrated lights out manager". I go to "Remote Control" and click on "Launch Console". After that, it download a JNLP file, called "jnlpgenerator-16". I open it with Java7 -web starter- update 5.

      After a while hanging I get this error:

      Error: Unable to load resource: https://XXX.XXX.XXX.XX:443/Java/JavaRConsole.jar.


      In Exception:

      com.sun.deploy.net.FailedDownloadException: Unable to load resource: https://XXX.XXX.XXX.XXX:443/Java/JavaRConsole.jar
           at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.getResource(Unknown Source)
           at com.sun.javaws.LaunchDownload$DownloadTask.call(Unknown Source)
           at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
           at java.util.concurrent.FutureTask.run(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
           at java.lang.Thread.run(Unknown Source)

      In Wrapped Exception:

      java.net.SocketException: SOCKS server general failure
           at java.net.SocksSocketImpl.connect(Unknown Source)
           at java.net.Socket.connect(Unknown Source)
           at sun.security.ssl.SSLSocketImpl.connect(Unknown Source)
           at sun.security.ssl.BaseSSLSocketImpl.connect(Unknown Source)
           at sun.net.NetworkClient.doConnect(Unknown Source)
           at sun.net.www.http.HttpClient.openServer(Unknown Source)
           at sun.net.www.http.HttpClient.openServer(Unknown Source)
           at sun.net.www.protocol.https.HttpsClient.<init>(Unknown Source)
           at sun.net.www.protocol.https.HttpsClient.New(Unknown Source)
           at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(Unknown Source)
           at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
           at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown Source)
           at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(Unknown Source)
           at com.sun.deploy.net.BasicHttpRequest.doRequest(Unknown Source)
           at com.sun.deploy.net.BasicHttpRequest.doRequest(Unknown Source)
           at com.sun.deploy.net.BasicHttpRequest.doGetRequest(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(Unknown Source)
           at com.sun.deploy.net.DownloadEngine.getResource(Unknown Source)
           at com.sun.javaws.LaunchDownload$DownloadTask.call(Unknown Source)
           at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
           at java.util.concurrent.FutureTask.run(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
           at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
           at java.lang.Thread.run(Unknown Source)


      It happens the same under Windows 7 and Linux -using openJRE and icedtea as substitution of Java Web Start-.

      I'm behind a proxy. In my browser -Chrome, IE and FF- putted the info of the proxy and I can browse. Aldo tried to put the info in the Java "Network Settings". It did not work -the launching of the console-.

      I installed the last Java Web Start in Windows 7 -Java7 Update5-. I disabled my anti-virus and firewall. Always the same result.

      Could you help me please. I don't have idea of what is going on.

      Greetings.

      PD: I tested from other machines of the company and it works. So, I guess is my laptop. I exported the oracle certificates from those machine and imported them into mine.