10 Replies Latest reply: Jul 20, 2012 7:23 AM by ReddyG RSS

    problem  with write back option in obiee 10g

    prassu
      Hi,
      I have a problem with writeback option in obiee 10g.I have created WriteBack.xml file and placed in oracleBI/web/msgdb/custommessages and oracleBIData/web/msgdb/custommessages .i disabled the cache for the table which applied writeback option.

      I enabled write back option for the one column at answers page.It is showing the write back button which i created,but it is disabled.

      I restarted the BI server,Presentation server and OC4J also.

      note:i have given the connection pool name and template name as i used in the writeback.xml
      operating system:windows XP
      OBIEE 10g

      Can anyone please resolve my issue.......
        • 1. Re: problem  with write back option in obiee 10g
          Dpka
          Did you grant writeback privilege?

          ->Login in OBI Presentation Service Website Setting / Administration / Manage Privileges. Grant the privilege “Write Back to database” to the permitted group

          ->In rpd ->Manage / Security->Grant the privilege “Execute Direct Database Access”

          Regards,
          Dpka
          • 2. Re: problem  with write back option in obiee 10g
            Satya Ranki Reddy
            Hi,

            please refer the bleow link and verify the configuration steps.

            http://satyaobieesolutions.blogspot.in/2012/06/obiee-10g11g-writeback-capabilities.html

            Hope this help's

            Thanks
            Satya
            • 3. Re: problem  with write back option in obiee 10g
              prassu
              Hi ,
              i have given the privileges at Answers but i didnt get the option (manage/security->execute direct datbase access) given by you....can you please tell me where this option is available..


              thanks,
              prasanna
              • 4. Re: problem  with write back option in obiee 10g
                user248025
                Go to RPD --> (Menu) Manage --->security--> right click properties of group/users and click permission button and select Query limit tab then you can find the “Execute Direct Database Access” just make it "Allow" its grand the permission users to insert/update tag to DB


                Refer my blog for more steps,
                http://obieeelegant.blogspot.com/2010/12/write-back-steps-1-go-to-repository.html

                Thanks
                Deva
                • 5. Re: problem  with write back option in obiee 10g
                  prassu
                  I have logged in as Administrator,so i have all th previleges.I have done all the steps what is required.But the writeback option is disabled..


                  can anyone please resolve the problem.

                  thanks,
                  prasanna
                  • 6. Re: problem  with write back option in obiee 10g
                    Srini VEERAVALLI
                    Check these
                    1) Settings->Manage Privileges->Write Back
                    a) Manage Write Back
                    b) Write Back to Database
                    2) XML file name at OracleBIData\web\msgdb and the content in the file

                    Pls mark if helps :)
                    • 7. Re: problem  with write back option in obiee 10g
                      prassu
                      I have given all the privileges from repository and answers both as well.
                      • 8. Re: problem  with write back option in obiee 10g
                        ReddyG
                        I also face similar kind of issue ..please check your writeback template is correct or not with any mistakes it should like this...


                        A couple of small adjustments got your XML to work here:

                        <?xml version="1.0"; encoding="utf-8"?>
                        <WebMessageTables xmlns:sawm="com.siebel.analytics.web/message/v1";>
                        <WebMessageTable lang="en-us" system="WriteBack" table="Messages">
                        <WebMessage name="WriteBack">
                        <XML>
                        <writeBack connectionPool="Connection Pool">
                        <insert> INSERT INTO FACT (PRICE,PRODUCT_KEY,REGION_KEY,SALE_UNIT,TIMEKEY,SALES_QUOTA)
                        values (@{c7},@{c8},@{c9},@{c10},@{c11},@{c5} ) </insert>
                        <update> </update>
                        </writeBack>
                        </XML>
                        </WebMessage>
                        </WebMessageTable>
                        </WebMessageTables>

                        The <writeBack> tag is written with a lower case "w".
                        The "connectionPool" needs an upper case "P".

                        Update--

                        I think that you have to specify also an SQL statement for the update tag, for example:

                        <?xml version="1.0"; encoding="utf-8"?>
                        <WebMessageTables xmlns:sawm="com.siebel.analytics.web/message/v1";>
                        <WebMessageTable lang="en-us" system="WriteBack" table="Messages">
                        <WebMessage name="pmet_update">
                        <XML>
                        <writeBack connectionPool="PMTCOG">
                        <insert> select null from dual</insert>
                        <update> UPDATE XREF_PMET_URL SET URL= '@{c1}' WHERE API='@{c0}'</update>
                        </writeBack>
                        </XML>
                        </WebMessage>
                        </WebMessageTable>
                        </WebMessageTables>
                        The witeback wants for both the tags (<insert></insert> and <update></update>) an SQL Statement.
                        • 9. Re: problem  with write back option in obiee 10g
                          prassu
                          Hi,
                          Mention the connection pool namewhich you are using for write back column.Use same Webmessage name at template at "Answers" while enabling the writeback option.

                          can you please tell me ,are you able to enable insert/update button......If yes tell me the solution to my question.

                          thanks,
                          prasanna..
                          • 10. Re: problem  with write back option in obiee 10g
                            ReddyG
                            yes..I am able to insert and Update with this template and connection pool name....I used Excel as my source...logged in as Admin user.

                            <?xml version="1.0" encoding="utf-8"?>
                            <WebMessageTables xmlns:sawm="com.siebel.analytics.web/message/v1">
                            <WebMessageTable lang="en-us" system="WriteBack" table="Messages">
                            <WebMessage name="writeback">
                            <XML>
                            <writeBack connectionPool="Connection Pool">
                            <insert>insert into DATA values('@{c0}','@{c1}',@{c2})</insert>
                            <update>update DATA SET "SCORE"=@{c2} WHERE "EMPID"='@{c0}' and "TESTID"='@{c1}'</update>
                            </writeBack>
                            </XML>
                            </WebMessage>
                            </WebMessageTable>
                            </WebMessageTables>


                            Becareful with mistakes like extra/wrong position ?,spaces in template..If u are using same Webmeaage name,Connection pool name try to copy/paste above code in ur template with appropriate changes with Insert/update command ...and restart services,see results. ...Good luck..


                            For reference.........
                            http://kpipartners.blogspot.in/2009/09/writeback-in-obiee.html