6 Replies Latest reply on Jul 24, 2012 8:55 AM by 951096

    Problem while running SOA Server

      Hi, i'm trying to starting SOA server. I started Admin Server successfully but I have problems while starting SOA server. When i'm trying to do that i get many errors, last three lines in console are following:

      12 mismatched character '<EOF>' expecting '"'
      tform is running and accepting requests
      12 mismatched character '<EOF>' expecting '"'

      When i'm trying to do start SOA server by administration console (settings of soa_server1 -> Control -> Start/Stop -> check soa_server1 and click Start) I get: Certificate chain received from localhost - failed hostname verification check. Certificate contained Pawe?-Komputer but check expected localhost

      Could you help me? If it will be necessary I will write more info.

      Thanks in advance

      Edited by: 948093 on 2012-07-23 06:07
        • 1. Re: Problem while running SOA Server
          Kalyan Pasupuleti-Oracle

          Try to set listen address for your SOA server and try to restart once.

          if you still get similar problem.

          Try to copy cacert of %Weblogic_Home%/ server / lib to %JDK_Home/ Jre/ lib/security/

          and clear tmp and cache folder of your SOA server and restart it again.

          • 2. Re: Problem while running SOA Server
            Thank you for your post.

            I tried to set listen address of SOA server to localhost and then to **, i copied cacert and restart Admin server and then tried to start SOA server. Unfortunately still the same error. Does exist another way to solve this problem?

            If it might be helpful i paste end of log (i tried start SOA server also by command startManagedWebLogic soa_server1 "" )

            Caused By: java.net.ConnectException: connect: Address is invalid on local machi
            ne, or port is not valid on remote machine
            at java.net.PlainSocketImpl.socketConnect(Native Method)
            at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:351)
            at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:213)
            at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:200)
            at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
            at java.net.Socket.connect(Socket.java:529)
            at java.net.Socket.connect(Socket.java:478)
            at java.net.Socket.<init>(Socket.java:375)
            at java.net.Socket.<init>(Socket.java:189)
            at com.sun.jndi.ldap.Connection.createSocket(Connection.java:352)
            at com.sun.jndi.ldap.Connection.<init>(Connection.java:187)
            at com.sun.jndi.ldap.LdapClient.<init>(LdapClient.java:118)
            at com.sun.jndi.ldap.LdapClient.getInstance(LdapClient.java:1580)
            at com.sun.jndi.ldap.LdapCtx.connect(LdapCtx.java:2652)
            at com.sun.jndi.ldap.LdapCtx.<init>(LdapCtx.java:293)
            at com.sun.jndi.ldap.LdapCtxFactory.getUsingURL(LdapCtxFactory.java:175)

            at com.sun.jndi.ldap.LdapCtxFactory.getUsingURLs(LdapCtxFactory.java:193
            at com.sun.jndi.ldap.LdapCtxFactory.getLdapCtxInstance(LdapCtxFactory.ja
            at com.sun.jndi.ldap.LdapCtxFactory.getInitialContext(LdapCtxFactory.jav
            at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:6
            at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:288
            at javax.naming.InitialContext.init(InitialContext.java:223)
            at javax.naming.ldap.InitialLdapContext.<init>(InitialLdapContext.java:1
            at oracle.security.idm.providers.stdldap.TestConnectionPool.run(LDIdenti
            line 3:12 mismatched character '<EOF>' expecting '"'
            SOA Platform is running and accepting requests
            • 3. Re: Problem while running SOA Server
              Kalyan Pasupuleti-Oracle

              Are you sure that your IP address is

              check for IPconfig in windows or ifconfig in unix environments.

              set correct IP address.

              • 4. Re: Problem while running SOA Server
                I installed and ran database, weblogic etc. local so i used But i tried to set IP address from ipconfig. After that i still got the same error.

                I saw also in administration console (on top of page):

                Warning For server soa_server1, the Node Manager associated with machine LocalMachine is not reachable.
                Warning All of the servers selected are currently in a state which is incompatible with this operation or are not associated with a running Node Manager or you are not authorized to perform the action requested. No action will be performed.

                I didn't use Node Manager - is it required?
                • 5. Re: Problem while running SOA Server
                  Kalyan Pasupuleti-Oracle

                  It seems when you call following command.

                  startManagedWebLogic soa_server1 ""

                  try this way.

                  startManagedWebLogic.sh soa_server1 t3://<IP machine > : <Port>

                  Make sure whether you had given Admin server port or not.

                  check your config file again to verify given port and IP address or correct.

                  • 6. Re: Problem while running SOA Server
                    Thank you - this startManagedWebLogic.sh soa_server1 t3://<IP machine > : <Port> worked!

                    I got some errors but server started. Again thanks!