This discussion is archived
3 Replies Latest reply: Aug 2, 2012 3:41 AM by gimbal2 RSS

ERROR: class file has wrong version 50.0, should be 49.0

853473 Newbie
Currently Being Moderated
Dear All,

I am having a J2EE application running on Java 5.
Now I have a requirement to use the different appliaction libraries (jar files).

After using the different appliaction library in my application, I am getting this error:
*********************
cannot access com.test.service.IConnection
ERROR: bad class file: D:<complete path for file>/service/IConnection.class)
[javac] ERROR: class file has wrong version 50.0, should be 49.0
[javac] ERROR: Please remove or make sure it appears in the correct subdirectory of the classpath.
[javac] ERROR: import com.test.service.IConnection;
*********************

I understand that there is mis-match in the Java versions used in my application and the other application where Jars are created.

Please suggest me how can I proceed (I cannot change my Java version as it is a requirement for one of my server.).

Regards,
Patana

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points