9 Replies Latest reply: Aug 10, 2012 7:25 PM by Avi Miller-Oracle RSS

    Missing Packages for Redhat

    user564785
      OS=Redhat 5
      Oracle 11.2.0.1

      During the installation of Oracle, I ran into some issues with missing packages. As a result, I could not complete the installation. Does anyone know where I can dowlonad free redhat 5 packages? I tried looking online and the ones I've downloaded does not seem to work.

      Jin
        • 1. Re: Missing Packages for Redhat
          Helios-GunesEROL
          Hi;

          You can not? Did you check missing rpms from DVD? It should be there.

          You can also check below thread:
          RPM confirmation

          Regard
          Helios
          • 2. Re: Missing Packages for Redhat
            rgulledg-Oracle
            If you have an Oracle Support contract, then please review the Database Install community on My Oracle Support (MOS) here...

            [https://communities.oracle.com/portal/server.pt/community/database_install/278|https://communities.oracle.com/portal/server.pt/community/database_install/278]

            ...particularly the section near the bottom with the title...

            "Database Install Product Specific"

            ...and the entry that starts with "If you use Oracle Database on a Linux system". The article there links to a reference list of various Linux and Oracle Database combinations. Select the one appropriate for your situation and it will display pretty much all you should need to get Linux setup correctly for an Oracle Database install.

            Regards,
            RichardG
            • 3. Re: Missing Packages for Redhat
              user564785
              I will check. which directory in the cd can i find the packages?
              • 4. Re: Missing Packages for Redhat
                Helios-GunesEROL
                Hi;
                I will check. which directory in the cd can i find the packages?
                You can put it on windows machine and can use search and can find rpm and move them to linux server or you can mount media to linux and can use find / -name rpm

                Regard
                Helios
                • 5. Re: Missing Packages for Redhat
                  12cdb
                  It seems you did not run the pre-requisite check, which should have spotted this well before you hit the issue.

                  As advissed earlier, you could find it in media or google.
                  • 6. Re: Missing Packages for Redhat
                    user564785
                    I was able to find most of the required packages on the DVD. However, when I try to install this package ( elfutils-libelf-devel-0.137-3.el5.x86_64.rpm) , its complaining about dependancies. When I try to install the software that it is dependant on, RPM complains that its dependant on the first packge that i originally tried to install. Any ideas?

                    [root@localhost packages]# ls -l elfutils-libelf-devel*
                    -rwxrwxrwx 1 root root 25112 Nov 4 2008 elfutils-libelf-devel-0.137-3.el5.i386.rpm
                    -rwxrwxrwx 1 root root 25098 Nov 4 2008 elfutils-libelf-devel-0.137-3.el5.x86_64.rpm
                    -rwxrwxrwx 1 root root 67614 Nov 4 2008 elfutils-libelf-devel-static-0.137-3.el5.i386.rpm
                    -rwxrwxrwx 1 root root 65436 Nov 4 2008 elfutils-libelf-devel-static-0.137-3.el5.x86_64.rpm
                    [root@localhost packages]# rpm -ivh elfutils-libelf-devel-0.137-3.el5.x86_64.rpm
                    warning: elfutils-libelf-devel-0.137-3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
                    error: Failed dependencies:
                    elfutils-libelf-devel-static-x86_64 = 0.137-3.el5 is needed by elfutils-libelf-devel-0.137-3.el5.x86_64
                    [root@localhost packages]# rpm -ivh elfutils-libelf-devel-static-0.137-3.el5.x86_64.rpm
                    warning: elfutils-libelf-devel-static-0.137-3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
                    error: Failed dependencies:
                    elfutils-libelf-devel-x86_64 = 0.137-3.el5 is needed by elfutils-libelf-devel-static-0.137-3.el5.x86_64
                    • 7. Re: Missing Packages for Redhat
                      user564785
                      I resolved this issue. i used --nodeps option.                                                                                                                                                                                                                   
                      • 8. Re: Missing Packages for Redhat
                        Catch_22
                        Some packages have a circular dependency. The solution would probably have been to install them together:

                        <pre>
                        rpm -Uvh elfutils-libelf-devel-0.137-3.el5.x86_64.rpm \
                        elfutils-libelf-devel-static-0.137-3.el5.x86_64.rpm
                        </pre>

                        or use yum instead of rpm which resolves dependencies automatically. the --nodeps is usually not a good idea because it installs software regardless of failing dependencies, which can break your system.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       
                        • 9. Re: Missing Packages for Redhat
                          Avi Miller-Oracle
                          user564785 wrote:
                          I resolved this issue. i used --nodeps option.
                          This is the wrong solution: you should enable ULN or public-yum.oracle.com and use yum to install the packages. This will automatically resolve the dependencies for you to ensure that all the software is correctly installed.