This content has been marked as final. Show 4 replies
Hi,1 person found this helpful
It depends on the usage. If you are using client listeners, where you want to get the id of the component to process, you can name them to have some meaning. However, there is no harm in keeping the default id as it is.
bast practice is to use meaning full value along with type of component. For example if you use <af:inputDate> for a From date Field.
Then recomended id would be id = "id_FmDt" [id_FmDt here id stands for inputDate ].
I do recall it mentioned in a video by Shay, I think, that said to keep the ID short for performance reasons, so you are correct in that.1 person found this helpful