2 Replies Latest reply: Aug 13, 2012 5:25 AM by 955397 RSS

    Libc.so.1 Version in Solaris 9 Branded zone

    955397
      Hi all,

      some applications (e.c. gawk from unixpackages,com) are failing at start:

      +# /usr/local/bin/gawk+
      ld.so.1: gawk: fatal: libc.so.1: version `SUNW_1.22' not found (required by file     /usr/local/bin/gawk)

      Latest Patchset is installed.

      When looking at /lib/libc.so.1 I get this versions:

      +# pvs /lib/libc.so.1+
      libdl.so.1 (SUNW_1.4, SUNWprivate_1.1);
      libc.so.1;
      SUNW_1.21.2;
      SUNW_1.21.1;
      SUNW_1.21;
      SUNW_1.20.4;
      SUNW_1.20.1;
      SUNW_1.20;
      SUNW_1.19;
      SUNW_1.18.1;
      SUNW_1.18;
      SUNW_1.17;
      SUNW_1.16;
      SUNW_1.15;
      SUNW_1.14;
      SUNW_1.13;
      SUNW_1.12;
      SUNW_1.11;
      SUNW_1.10;
      SUNW_1.9;
      SUNW_1.8;
      SUNW_1.7;
      SUNW_1.6;
      SUNW_1.5;
      SUNW_1.4;
      SUNW_1.3;
      SUNW_1.2;
      SUNW_1.1;
      SUNW_0.9;
      SUNW_0.8;
      SUNW_0.7;
      SISCD_2.3;
      SYSVABI_1.3;
      SUNWprivate_1.2;
      SUNWprivate_1.1;

      There are newer versions in /.SUNWnative/lib. The 3 directories /.SUNWnative/{lib,platform,usr} are mounted when booting the zone but I have no idea who they will be used..

      Can anyone help please?

      Thank you & regards,

      Michael