This discussion is archived
0 Replies Latest reply: Aug 14, 2012 12:35 AM by Latit RSS

LDAP Configuration

Latit Newbie
Currently Being Moderated
Hi All

Have anyone did the LDAP configuration with endeca workbench earlier. I was able to

1) Enable the ldap for workbench and now I am able to add LDAP users and LDAP groups too

2) I have configured the login.config file with the LDAP server details

But still I am not able to connect with user name

Now When I am doing check username ,It shows some errors saying some configuration issue.Can some one please advise

Thanks


Login.config file



Webstudio {
com.endeca.etools.ldap.LDAPLoginModule required
serverInfo="ldaps://ssl-example.endeca.com:636"
serviceUsername="cn=Manager,dc=endeca,dc=com"
servicePassword="secret"
serviceAuthentication="simple"
authentication="simple"
useSSL="true"
keyStoreLocation="C:/Endeca/MDEXEngine/workspace/conf/webstudio.jks"
keyStorePassphrase="keypass";

// The query used to look up a user in the LDAP directory and
// templates that extract information from the user object
userPath="/ou=users,dc=endeca,dc=com??sub?(uid=%{#username})"
userTemplate="%{#uid}"
firstNameTemplate="%{#givenName}"
lastNameTemplate="%{#sn}"
emailTemplate="%{#mail}"

// The query used to look up a group in the LDAP directory and
// templates that extract information from the group object
findGroupPath="/ou=groups,dc=endeca,dc=com??sub?(cn=%{#groupname})"
findGroupTemplate="%{#dn:0}"
groupEmailTemplate="%{#mail}"

// The query and template used to fetch the groups associated
// with a user when the user logs in to Web Studio
groupPath="/ou=groups,dc=endeca,dc=com??sub?(member=%{#dn})"
groupTemplate="%{#dn:0}"
};

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points