This discussion is archived
0 Replies Latest reply: Aug 14, 2012 4:55 AM by 836947 RSS

Launching Asset Editor in OER throws exception

836947 Newbie
Currently Being Moderated
Hi,

While Launching Asset Editor, in the middle of my work, I started facing one issue.

From OER Console (http://localhost:7101/oer), when I click on Edit/Manage Assets Link, it downloads registrartool.jnlp file.

When I double click on this file, It launches Asset Editor but this editor does not have Action Menu and also, it does not show any assets under different folders.

On Server, I get exception as

com.componentregistry.util.CMException: User is not logged in##5##1000##13449439
31209
at com.componentregistry.util.CMException.<clinit>(CMException.java:10)
at com.componentregistry.servlet.CMEEBaseServlet.service(CMEEBaseServlet
.java:37)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run
(StubSecurityHelper.java:227)
at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecuri
tyHelper.java:125)
at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.jav
a:300)
at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.jav
a:183)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationActio
n.wrapRun(WebAppServletContext.java:3717)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationActio
n.run(WebAppServletContext.java:3681)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(Authenticate
dSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:
120)
at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppS
ervletContext.java:2277)
at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletC
ontext.java:2183)
at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.j
ava:1454)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:178)
com.componentregistry.util.CMException: User is not logged in##5##1000##13449439
31209

Looks as while launching jnlp file, security context was not carried. Did anyone face this issue? Earlier it was working fine. Just in the middle, it started giving this error.

I have deleted all temp files from my machine. I have deleted server's tmp folder which contains cache but it is of no help.

If anyone has faced this issue, Please suggest.

Thanks,
Parshant

Edited by: 833944 on 14-Aug-2012 04:55

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points