1 Reply Latest reply on Aug 16, 2012 7:54 AM by Sheng Qu-Oracle

    Supporting Documents using URL fail

      We are trying to link documents on our SharePoint system into Agile via the Supporting Documents tab and using the URL link. The documentation doesn't say what is allowed or not, but on experimenting I've found that I can only link using a URL if it starts with http:// and ends with .html. So something like http://sharepoint/test.doc will fail to load and it will report the error "Invalid URL has been used....." I even tried using a UNC link to get to a file and that failed as well.

      Are we doing something wrong?, or is that how it is?
        • 1. Re: Supporting Documents using URL fail
          Sheng Qu-Oracle
          For some reason, we restricted the URL in a format like:
          http://host.domain/file.type   (Any type is OK here, not just ".html")
          If you have a full domain address for the sharepoint server, please just use that to instead.
          The URL should be something like: "http://sharepoint.internaldomain/test.doc"

          Also, we have configurations to disable the URL format restriction.

          To turn it off, you just need to add the following entries to CustomSettings.xml\<FeatureConfig>
          <add key="GSM.URLAttachment.ValidateProperURLFormatting.Enabled" value="false" configDescription="enable the URL validator"/>
          <add key="SCRM.URLAttachment.ValidateProperURLFormatting.Enabled" value="false" configDescription="enable the URL validator"/>
          <add key="NPD.URLAttachment.ValidateProperURLFormatting.Enabled" value="false" configDescription="enable the URL validator"/>     
          By this way, you can input the URL as what you motioned: http://sharepoint/test.doc

          However, it is important to note that:
          If you turn the valuator off, user can input everything here (including JavaScript command). This may bring some potential security problems.

          So, we definitely do NOT recommend turning these settings off.

          "UNC link" is not supported. Please open a SR if you really want this.


          Edited by: Sheng Qu on Aug 16, 2012 12:53 AM

          Edited by: Sheng Qu on Aug 16, 2012 12:53 AM