This discussion is archived
4 Replies Latest reply: Aug 16, 2012 4:46 PM by Dude! RSS

Oracle 11gR2 certification for Oracle Linux 6

Dude! Guru
Currently Being Moderated
Hello,

According to Oracle documentation, database certification and support for Oracle 11gR2 under Oracle Linux starts with 11.2.0.3.

I was wondering if this might have anything to do with the i386 software prerequisites. Speaking of Oracle 11gR2 x86_64, the need for i386 libraries was removed with 11gR2 11.2.0.2. Or in other words, one can go straight to 11.2.0.2 without the need to install any 32-bit libraries.

Under Oracle Linux 5 x86_64, the "oracle-validated" package triggers the installation of several i386 packages. Under Oracle Linux 6 x86_64, the oracle-rdbms-server-11gr2-preinstall package uses x86_64 only. Under Oracle Linux 6, i386 changed to i686.

For what it's worth, I have installed Oracle 11gR2 database 11.2.0.1 under Oracle Linux 6.1 to 6.3, both x86_64, simply by using the oracle-rdbms-server-11gr2-preinstall package, and so far have not noticed any problems. Is there some information available, why 11.2.0.1 (x86_64) should not be used or is not certified for Oracle Linux 6 (x86_64)?

Thanks.
  • 1. Re: Oracle 11gR2 certification for Oracle Linux 6
    TommyReynolds Expert
    Currently Being Moderated
    Go to http://support.oracle.com and visit the CERTIFICATIONS tab. After the appropriate drilling down (select product, version, and platform):

    "Oracle Database 11.2.0.3.0 is certified on Linux x86 Oracle Linux 6"
  • 2. Re: Oracle 11gR2 certification for Oracle Linux 6
    Dude! Guru
    Currently Being Moderated
    I would like to know why 11.2.0.1 (x86_64) is not certified for OL 6. I know there is trouble with the Grid installer and the new upstart daemon, which starts to work in 11.2.0.3, but the problem is not difficult to work around.

    It means only users with access to Oracle support can or should use 11gR2 for Oracle Linux 6. Only 11.2.0.1 is available from OTN.

    What is the trouble with Oracle 11g database 11.2.0.1 (x86_64) under Oracle Linux 6? As far as I can tell everything seems to work fine, even without installing the i386 libraries.
  • 3. Re: Oracle 11gR2 certification for Oracle Linux 6
    Avi Miller Guru
    Currently Being Moderated
    Dude wrote:
    I would like to know why 11.2.0.1 (x86_64) is not certified for OL 6. I know there is trouble with the Grid installer and the new upstart daemon, which starts to work in 11.2.0.3, but the problem is not difficult to work around.
    Database certification is the responsibility of the Database team, not the Linux team. This is the wrong forum for this question.
  • 4. Re: Oracle 11gR2 certification for Oracle Linux 6
    Dude! Guru
    Currently Being Moderated
    I was afraid of that. Since the question is Oracle Linux 6 specific, I thought I'd try my luck here, thinking that if I get an answer, then probably here. Maybe it was not very realistic to get an answer anyway.

    For what it's worth. Using "oracle-validated" under Oracle Linux 5, and "oracle-rdbms-server-11gR2-preinstall" under Oracle Linux 6, I was able to install Oracle 11gR2 11.2.0.1 just fine, both platforms x86_64 and 32-bit. I have not found any operational issues yet and it seems to run perfectly well.

    The only trouble I had was with Grid Infrastructure 11.2.0.1, and here 11.2.0.3 is indeed required for it to install. I made a custom patch, just a few lines and after that 11.2.0.1, both x86_64 and 32-bit installed just fine and is fully operational.

    I'm though I could post the patch. I guess it might make those people happy who do not have access to Oracle support and download 11.2.0.3. The patch will allow them to use the 11gR2 OTN version and install it under Oracle Linux 6. It won't be certified, but it is good enough for the purpose of education.

    I'm closing the thread.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points