3 Replies Latest reply: Oct 26, 2012 6:11 AM by user1769454 RSS

    1.7 and 1.6 side by side?

      Hi Folks,

      I've updated Java to 1.7, but I run a program that doesn't work on 1.7 (it only works on 1.6). Is there any way for me to run 1.7 and 1.6 on the same computer, and to run this program with 1.6 instead of 1.7?

      I'm running Windows 7 Pro x64. Installed on my computer are the following:
      J2SE Runtime Environment 5.0 update 15
      Java 6 update 33
      Java 7 update 5
      JavaFX 2.1.1 (64-bit)
      JavaFX 2.1.1 SDK (64-bit)

      thank you!
        • 1. Re: 1.7 and 1.6 side by side?
          You already have it running side by side. The only trouble is that the software needs to be built such that you can force it to use a specific installation of Java. It seems to want to use the 'default' one. Only way to find out is to check the documentation of said software or to contact customer service.
          • 2. Re: 1.7 and 1.6 side by side?
            I have a similar situation. I have a server equipped with an early Dell Remote Access Card (DRAC). The console-view function requires Java 1.6, and it won't operate if 1.7 is installed. I have found a workaround that may work for you as well: Open the Java applet in Control Panel, then click on the Java tab, then View. You will see your installed Java versions. If I uncheck 1.7 but leave 1.6 checked, I can view my DRAC console. When done I reenable 1.7.

            Note that since I installed 1.7u6, there is a new warning message (see thread, "Goofy error message, jre7u6"). This does not prevent me from viewing my DRAC console; it's just annoying.

            • 3. Re: 1.7 and 1.6 side by side?
              I do the same when running Oracle Forms 10G, which is not certified for 1.7, BUT does someone know how to make this change automatically ie. in a script so that it can be done just before the application starts.