11 Replies Latest reply: Aug 28, 2012 10:28 PM by René van Wijk RSS

    Failed to initialize the  'inventory' after setting the weblogic classpath

    957500
      I have installed Webservice as a seperate application(not bundled with ear). while invoking webservice it's showing following error :


      <WSEE>
      Error invoking oracle.communications.inventory.webservice.ws.MetroUimWsPortImpl (POJO): java.lang.NoClassDefFoundError<ComponentHandler.handleRequest:115>
      <WSEE>java.lang.NoClassDefFoundError: oracle/communications/inventory/api/framework/logging/LogFactory<ComponentHandler.handleRequest:115>

      Assuming that its because of missing mslv-api-framework.jar in the classpath, I have setted the classpath in the setDomainEnv.sh file and restarted the server. After this , webservice is getting invoked but inventory.ear is in new state and is showing error like

      <Error> <Deployer> <BEA-149205> <Failed to initialize the application 'inventory' due to error weblogic.application.ModuleException: [1] The ra.xml <managedconnectionfactory-class> class 'oracle.communications.inventory.api.framework.persistence.OracleManagedConnectionFactory' could not be loaded from the resource adapter archive/application because of the following error: java.lang.NoClassDefFoundError: kodo/jdbc/ee/JDBCManagedConnectionFactory
      [2] The ra.xml <connectionfactory-impl-class> class 'oracle.communications.inventory.api.framework.persistence.OracleConnectionFactory' could not be loaded from the resource adapter archive/application because of the following error: java.lang.NoClassDefFoundError: kodo/jdbc/ee/JDBCConnectionFactory.
      weblogic.application.ModuleException: [1] The ra.xml <managedconnectionfactory-class> class 'oracle.communications.inventory.api.framework.persistence.OracleManagedConnectionFactory' could not be loaded from the resource adapter archive/application because of the following error: java.lang.NoClassDefFoundError: kodo/jdbc/ee/JDBCManagedConnectionFactory
      [2] The ra.xml <connectionfactory-impl-class> class 'oracle.communications.inventory.api.framework.persistence.OracleConnectionFactory' could not be loaded from the resource adapter archive/application because of the following error: java.lang.NoClassDefFoundError: kodo/jdbc/ee/JDBCConnectionFactory
      at weblogic.connector.deploy.ConnectorModule.prepare(ConnectorModule.java:207)
      at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:93)
      at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:360)
      at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:26)
      at weblogic.application.internal.flow.DeploymentCallbackFlow.prepare(DeploymentCallbackFlow.java:56)



      Before setting the classpath the inventory.ear file was in active state .
      We are using Weblogic server version 9.2

      Could anyone help me with this ?