4 Replies Latest reply: Aug 28, 2012 11:08 AM by 1502 RSS

    rdate in solaris 11

    1502
      how can i enable the rdate services in solaris 11
        • 1. Re: rdate in solaris 11
          bobthesungeek76036
          Not sure about Solaris 11 but in Solaris 10 you type:

          <pre>
          svcadm enable time:stream
          svcadm enable time:dgram
          </pre>

          to enable rdate service. But the bigger question is why??? ntp is much more secure and more widely used these days...
          • 2. Re: rdate in solaris 11
            1502
            I get the following error when i run the default commands. any ideas?

            # svcs -xv svc:network/time:stream
            svc:/network/time:stream (?)
            State: -
            Reason: Service is incomplete, defined only by profile /etc/svc/profile/generic.xml
            Impact: This service is not running.

            # svcs -xv svc:network/time:dtgram
            svcs: Pattern 'svc:network/time:dtgram' doesn't match any instances

            Yes, but rdate is coming from very old VxWorks systems that cannot be modified. So we are stuck with rdate.
            • 3. Re: rdate in solaris 11
              Dave Miner-Oracle
              Since it's not a recommended service any longer, it's not installed by default. "pkg search in.timed" will get you the package name (service/network/legacy-network-services). Once you install it, you'll be able to enable it as Bob suggests.
              • 4. Re: rdate in solaris 11
                1502
                Thank-You
                It worked !!! :)