0 Replies Latest reply: Aug 31, 2012 9:36 AM by 959325 RSS

    upgrade to SRU8.5 using local repository failed .

    959325
      We downloaded the ISO image of latest SRU (8.5) and created local repository.
      When we tried to upgrade a solaris 11 GA to SRU 8.5, we got following error.
      Is it that in order to upgrade to latest SRU, al the previous SRUs need to be installed in that order?
      When we upgraded to SRU 8.5 from oracle’s online repo, it worked.


      root@test:~# pkg update -nv
      Creating Plan -
      pkg update: No solution was found to satisfy constraints
      Plan Creation: Package solver has not found a solution to update to latest available versions.
      This may indicate an overly constrained set of packages are installed.

      latest incorporations:

      pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.8.0.5.1:20120618T173352Z
      pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.0.8.0.4.0:20120601T170434Z
      pkg://solaris/consolidation/install/install-incorporation@0.5.11,5.11-0.175.0.7.0.2.0:20120416T210633Z
      pkg://solaris/consolidation/SunVTS/SunVTS-incorporation@0.5.11,5.11-0.175.0.7.0.3.0:20120421T004225Z
      pkg://solaris/consolidation/ub_javavm/ub_javavm-incorporation@0.5.11,5.11-0.175.0.8.0.4.0:20120604T164023Z
      pkg://solaris/consolidation/ips/ips-incorporation@0.5.11,5.11-0.175.0.7.0.4.0:20120430T200820Z
      pkg://solaris/consolidation/ldoms/ldoms-incorporation@0.5.11,5.11-0.175.0.8.0.3.0:20120525T222045Z
      pkg://solaris/consolidation/desktop/gnome-incorporation@0.5.11,5.11-0.175.0.8.0.3.0:20120524T231910Z
      pkg://solaris/consolidation/desktop/desktop-incorporation@0.5.11,5.11-0.175.0.8.0.3.0:20120524T231907Z
      pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z
      pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.0.8.0.2.1226:20120519T002403Z
      pkg://solaris/consolidation/cacao/cacao-incorporation@0.5.11,5.11-0.175.0.6.0.1.0:20120323T204721Z

      The following indicates why the system cannot update to the latest version:

      No suitable version of required package pkg://solaris/consolidation/ub_javavm/ub_javavm-incorporation@0.5.11,5.11-0.175.0.8.0.4.0:20120604T164023Z found:
      Reject: pkg://solaris/consolidation/ub_javavm/ub_javavm-incorporation@0.5.11,5.11-0.175.0.8.0.4.0:20120604T164023Z
      Reason: All versions matching 'incorporate' dependency pkg:/runtime/java/jre-6@1.6.0.32,5.11-0.175.0.8.0.4.0 are rejected
      Reject: pkg://solaris/runtime/java/jre-6@1.6.0.32,5.11-0.175.0.8.0.4.0:20120604T164136Z
      Reason: A version for 'require' dependency on pkg:/system/library/c++/sunpro@0.5.11,5.11-0.164 cannot be found
      No suitable version of required package pkg://solaris/runtime/java@1.6.0.32,5.11-0.175.0.8.0.4.0:20120604T164207Z found:
      Reject: pkg://solaris/runtime/java@1.6.0.32,5.11-0.175.0.8.0.4.0:20120604T164207Z
      Reason: All versions matching 'require' dependency pkg:/runtime/java/jre-6@1.6.0.32,5.11-0.175.0.8.0.4.0 are rejected
      Reject: pkg://solaris/runtime/java/jre-6@1.6.0.32,5.11-0.175.0.8.0.4.0:20120604T164136Z
      Reason: A version for 'require' dependency on pkg:/system/library/c++/sunpro@0.5.11,5.11-0.164 cannot be found

      Edited by: 956322 on Aug 31, 2012 7:35 AM