3 Replies Latest reply: Sep 8, 2012 12:54 AM by Kalyan Pasupuleti-Oracle RSS

    Problem Cloning a Managed Server

    950801
      Hello,


      I am trying to add a managed server to an OSB CLUSTER with Weblogic Version 11.1.1.3.
      What I am doing is cloning an existing NODE but with a diferent Listen Port.
      And when I try to start it, I obtain the following error:


      bash-3.2$ tail -f osb_server4.out
      * To start WebLogic Server, use a username and *
      * password assigned to an admin-level user. For *
      * server administration, use the WebLogic Server *
      * console at http://hostname:port/console *
      ***************************************************
      starting weblogic with Java version:
      ERROR: transport error 202: bind failed: Address already in use
      ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
      JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:690]
      FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)





      Abort - core dumped
      Starting WLS with line:
      /usr/jdk/instances/jdk1.6.0/bin/java -client -d64 -Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,address=8455,server=y,suspend=n -Djava.compiler=NONE -d64 -XX:+UseConcMarkSweepGC -Xms4096m -Xmx4096m -XX:PermSize=256m -XX:MaxPermSize=512m -Dweblogic.Name=osb_server4 -Djava.security.policy=/soaosbt/Oracle/OSB_Middleware/wlserver_10.3/server/lib/weblogic.policy -Dweblogic.system.BootIdentityFile=/soaosbt/Oracle/OSB_Middleware/user_projects/domains/soasoat_osb_domain/servers/osb_server4/data/nodemanager/boot.properties -Dweblogic.nodemanager.ServiceEnabled=true -Dweblogic.security.SSL.ignoreHostnameVerification=true -Dweblogic.ReverseDNSAllowed=false -Xverify:none -da:org.apache.xmlbeans... -ea -da:com.bea... -da:javelin... -da:weblogic... -ea:com.bea.wli... -ea:com.bea.broker... -ea:com.bea.sbconsole... -Dplatform.home=/soaosbt/Oracle/OSB_Middleware/wlserver_10.3 -Dwls.home=/soaosbt/Oracle/OSB_Middleware/wlserver_10.3/server -Dweblogic.home=/soaosbt/Oracle/OSB_Middleware/wlserver_10.3/server -Dcommon.components.home=/soaosbt/Oracle/OSB_Middleware/oracle_common -Djrf.version=11.1.1 -Dorg.apache.commons.logging.Log=org.apache.commons.logging.impl.Jdk14Logger -Ddomain.home=/soaosbt/Oracle/OSB_Middleware/user_projects/domains/soasoat_osb_domain -Djrockit.optfile=/soaosbt/Oracle/OSB_Middleware/oracle_common/modules/oracle.jrf_11.1.1/jrocket_optfile.txt -Doracle.server.config.dir=/soaosbt/Oracle/OSB_Middleware/user_projects/domains/soasoat_osb_domain/config/fmwconfig/servers/osb_server4 -Doracle.domain.config.dir=/soaosbt/Oracle/OSB_Middleware/user_projects/domains/soasoat_osb_domain/config/fmwconfig -Digf.arisidbeans.carmlloc=/soaosbt/Oracle/OSB_Middleware/user_projects/domains/soasoat_osb_domain/config/fmwconfig/carml -Digf.arisidstack.home=/soaosbt/Oracle/OSB_Middleware/user_projects/domains/soasoat_osb_domain/config/fmwconfig/arisidprovider -Doracle.security.jps.config=/soaosbt/Oracle/OSB_Middleware/user_projects/domains/soasoat_osb_domain/config/fmwconfig/jps-config.xml -Doracle.deployed.app.dir=/soaosbt/Oracle/OSB_Middleware/user_projects/domains/soasoat_osb_domain/servers/osb_server4/tmp/_WL_user -Doracle.deployed.app.ext=/- -Dweblogic.alternateTypesDirectory=/soaosbt/Oracle/OSB_Middleware/oracle_common/modules/oracle.ossoiap_11.1.1,/soaosbt/Oracle/OSB_Middleware/oracle_common/modules/oracle.oamprovider_11.1.1 -Djava.protocol.handler.pkgs=oracle.mds.net.protocol -Dweblogic.jdbc.remoteEnabled=false -Dem.oracle.home=/soaosbt/Oracle/OSB_Middleware/oracle_common -Djava.awt.headless=true -Dweblogic.management.discover=false -Dweblogic.management.server=http://192.168.183.178:7201 -Dwlw.iterativeDev= -Dwlw.testConsole= -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=/soaosbt/Oracle/OSB_Middleware/patch_wls1034/profiles/default/sysext_manifest_classpath:/soaosbt/Oracle/OSB_Middleware/patch_ocp360/profiles/default/sysext_manifest_classpath weblogic.Server
      ERROR: transport error 202: bind failed: Address already in use
      ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
      JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:690]
      FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)




      I have read that this error could be caused for a Port Used by another application o a problem with the debug port.
      But the port that I am setting is free (Checked with netstat ) and the Debbug is not enable.


      I would appreciate some help.