1 Reply Latest reply: Oct 10, 2012 6:14 AM by Isti RSS

    bi_server1 is missing in Weblogic Admin Console

    user489948
      Hello Experts,

      I still have not figure out this issue, could anyone please help me, and let me know what caused this problem, and how to fix it. It is my first time to work on BI.

      I have installed Oracle BI Publisher 11.1.1.6.0 component only with simple installation type in Linux box. After installation, everything was OK. I was able to logon to Weblogic Server Admin Console, and BI Publisher Server. I was able to create Data Models/reports, schedule the jobs......

      However, after reboot the server (the server was not shutdown properly!), I have started up the Weblogic server with startWebLogic.sh seccessfully. But I am not able to see the bi_server1 in Administration Console from bifoundation_domain->Environment->Servers (Summary of Servers), ONLY "AdminServer(admin)" listed there!!!

      Then I started Node manager with startNodeManager.sh successfully and message "INFO: Secure socket listener started on port 5556" is in the log file.
      But when I tried to start bi_server1 using startManagedWebLogic.sh, and got following message:
      SVR_GRP =
      .
      .
      JAVA Memory arguments: -Xms256m -Xmx2048m -XX:MaxPermSize=512m -XX:-UseSSE42Intrinsics
      .
      WLS Start Mode=Production
      .
      CLASSPATH=/apps/oraMW/oracle_common/modules/oracle.jdbc_11.1.1/ojdbc6dms.jar:/apps/oraMW/Oracle_BI1/bifoundation/jdbc/jdk16/bijdbc.jar::/apps/oraMW/patch_wls1035/profiles/default/sys_manifest_classpath/weblogic_patch.jar:/apps/oraMW/Oracle_BI1/jdk/lib/tools.jar:/apps/oraMW/wlserver_10.3/server/lib/weblogic_sp.jar:/apps/oraMW/wlserver_10.3/server/lib/weblogic.jar:/apps/oraMW/modules/features/weblogic.server.modules_10.3.5.0.jar:/apps/oraMW/wlserver_10.3/server/lib/webservices.jar:/apps/oraMW/modules/org.apache.ant_1.7.1/lib/ant-all.jar:/apps/oraMW/modules/net.sf.antcontrib_1.1.0.0_1-0b2/lib/ant-contrib.jar:/apps/oraMW/wlserver_10.3/server/lib/weblogic.jar:/apps/oraMW/oracle_common/modules/oracle.dms_11.1.1/dms.jar:/apps/oraMW/oracle_common/modules/oracle.jmx_11.1.1/jmxframework.jar:/apps/oraMW/oracle_common/modules/oracle.jmx_11.1.1/jmxspi.jar:/apps/oraMW/oracle_common/modules/oracle.odl_11.1.1/ojdl.jar:/apps/oraMW/oracle_common/soa/modules/commons-cli-1.1.jar:/apps/oraMW/oracle_common/soa/modules/oracle.soa.mgmt_11.1.1/soa-infra-mgmt.jar:/apps/oraMW/oracle_common/modules/oracle.jrf_11.1.1/jrf.jar:/apps/oraMW/wlserver_10.3/common/derby/lib/derbyclient.jar:/apps/oraMW/wlserver_10.3/server/lib/xqrl.jar:/apps/oracle/product/db11.2.0.3/db_1/JRE:/apps/oracle/product/db11.2.0.3/db_1/jlib:/apps/oracle/product/db11.2.0.3/db_1/rdbms/jlib:/apps/oracle/product/db11.2.0.3/db_1/network/jlib
      .
      PATH=/apps/oraMW/wlserver_10.3/server/bin:/apps/oraMW/modules/org.apache.ant_1.7.1/bin:/apps/oraMW/Oracle_BI1/jdk/jre/bin:/apps/oraMW/Oracle_BI1/jdk/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/mit/bin:/usr/lib/mit/sbin:/apps/oracle/product/db11.2.0.3/db_1/bin
      .
      ***************************************************
      * To start WebLogic Server, use a username and *
      * password assigned to an admin-level user. For *
      * server administration, use the WebLogic Server *
      * console at http://hostname:port/console *
      ***************************************************
      starting weblogic with Java version:
      java version "1.6.0_29"
      Java(TM) SE Runtime Environment (build 1.6.0_29-b11)
      Java HotSpot(TM) 64-Bit Server VM (build 20.4-b02, mixed mode)
      Starting WLS with line:
      /apps/oraMW/Oracle_BI1/jdk/bin/java -server -Xms256m -Xmx2048m -XX:MaxPermSize=512m -XX:-UseSSE42Intrinsics -Dweblogic.Name=bi_server1 -Djava.security.policy=/apps/oraMW/wlserver_10.3/server/lib/weblogic.policy -Dweblogic.ProductionModeEnabled=true -Dweblogic.security.SSL.trustedCAKeyStore=/apps/oraMW/wlserver_10.3/server/lib/cacerts -da -Dplatform.home=/apps/oraMW/wlserver_10.3 -Dwls.home=/apps/oraMW/wlserver_10.3/server -Dweblogic.home=/apps/oraMW/wlserver_10.3/server -Dcommon.components.home=/apps/oraMW/oracle_common -Djrf.version=11.1.1 -Dorg.apache.commons.logging.Log=org.apache.commons.logging.impl.Jdk14Logger -Ddomain.home=/apps/oraMW/user_projects/domains/bifoundation_domain -Djrockit.optfile=/apps/oraMW/oracle_common/modules/oracle.jrf_11.1.1/jrocket_optfile.txt -Doracle.server.config.dir=/apps/oraMW/user_projects/domains/bifoundation_domain/config/fmwconfig/servers/bi_server1 -Doracle.domain.config.dir=/apps/oraMW/user_projects/domains/bifoundation_domain/config/fmwconfig -Digf.arisidbeans.carmlloc=/apps/oraMW/user_projects/domains/bifoundation_domain/config/fmwconfig/carml -Digf.arisidstack.home=/apps/oraMW/user_projects/domains/bifoundation_domain/config/fmwconfig/arisidprovider -Doracle.security.jps.config=/apps/oraMW/user_projects/domains/bifoundation_domain/config/fmwconfig/jps-config.xml -Doracle.deployed.app.dir=/apps/oraMW/user_projects/domains/bifoundation_domain/servers/bi_server1/tmp/_WL_user -Doracle.deployed.app.ext=/- -Dweblogic.alternateTypesDirectory=/apps/oraMW/oracle_common/modules/oracle.ossoiap_11.1.1,/apps/oraMW/oracle_common/modules/oracle.oamprovider_11.1.1 -Djava.protocol.handler.pkgs=oracle.mds.net.protocol -Dweblogic.jdbc.remoteEnabled=false -Dbi.oracle.home=/apps/oraMW/Oracle_BI1 -DEPM_ORACLE_HOME=/apps/oraMW/Oracle_BI1 -Dweblogic.MaxMessageSize=50000000 -DEPM_ORACLE_HOME=/apps/oraMW/Oracle_BI1 -DHYPERION_HOME=/apps/oraMW/Oracle_BI1 -DEPM_ORACLE_INSTANCE=novalue -Dhyperion.home=/apps/oraMW/Oracle_BI1 -DEPM_REG_PROPERTIES_PATH=/apps/oraMW/user_projects/domains/bifoundation_domain/config/fmwconfig -Depm.useApplicationContextId=false -Doracle.biee.search.bisearchproperties=/apps/oraMW/Oracle_BI1/bifoundation/jee/BISearchConfig.properties -Dweblogic.management.clearTextCredentialAccessEnabled=true -Doracle.notification.filewatching.interval=2000 -Dweblogic.security.SSL.ignoreHostnameVerification=true -Dweblogic.security.SSL.enableJSSE=true -Dfile.encoding=utf-8 -Dxdo.server.config.dir=/apps/oraMW/user_projects/domains/bifoundation_domain/config/bipublisher -DXDO_FONT_DIR=/apps/oraMW/Oracle_BI1/common/fonts -Dem.oracle.home=/apps/oraMW/oracle_common -Djava.awt.headless=true -Dweblogic.management.discover=false -Dweblogic.management.server=t3://myserver:7001 -Dwlw.iterativeDev=false -Dwlw.testConsole=false -Dwlw.logErrorsToConsole=false -Dweblogic.ext.dirs=/apps/oraMW/patch_wls1035/profiles/default/sysext_manifest_classpath weblogic.Server
      <Sep 6, 2012 10:50:11 AM EDT> <Info> <Security> <BEA-090905> <Disabling CryptoJ JCE Provider self-integrity check for better startup performance. To enable this check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=true>
      <Sep 6, 2012 10:50:11 AM EDT> <Info> <Security> <BEA-090906> <Changing the default Random Number Generator in RSA CryptoJ from ECDRBG to FIPS186PRNG. To disable this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true>
      <Sep 6, 2012 10:50:12 AM EDT> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) 64-Bit Server VM Version 20.4-b02 from Sun Microsystems Inc.>
      <Sep 6, 2012 10:50:18 AM EDT> <Info> <Management> <BEA-141107> <Version: WebLogic Server 10.3.5.0 Fri Apr 1 20:20:06 PDT 2011 1398638 >
      <Sep 6, 2012 10:50:21 AM EDT> <Info> <Management> <BEA-141223> <The server name bi_server1 specified with -Dweblogic.Name does not exist. The configuration includes the following servers {AdminServer}.>
      <Sep 6, 2012 10:50:21 AM EDT> <Critical> <WebLogicServer> <BEA-000362> <Server failed. Reason:

      There are 1 nested errors:

      weblogic.management.ManagementException: [Management:141223]The server name bi_server1 specified with -Dweblogic.Name does not exist. The configuration includes the following servers {AdminServer}.
      at weblogic.management.provider.internal.RuntimeAccessImpl.<init>(RuntimeAccessImpl.java:149)
      at weblogic.management.provider.internal.RuntimeAccessService.start(RuntimeAccessService.java:41)
      at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesManager.java:461)
      at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServicesManager.java:166)
      at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:881)
      at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:568)
      at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:469)
      at weblogic.Server.main(Server.java:71)

      >
      <Sep 6, 2012 10:50:21 AM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED>
      <Sep 6, 2012 10:50:21 AM EDT> <Error> <WebLogicServer> <BEA-000383> <A critical service failed. The server will shut itself down>
      <Sep 6, 2012 10:50:21 AM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>

      Thanks for your help!!!

      Edited by: user489948 on Sep 6, 2012 8:41 AM
        • 1. Re: bi_server1 is missing in Weblogic Admin Console
          Isti
          user489948 wrote:
          <Sep 6, 2012 10:50:21 AM EDT> <Info> <Management> <BEA-141223> <The server name bi_server1 specified with -Dweblogic.Name does not exist. The configuration includes the following servers {AdminServer}.>
          The above message suggests that there is no managed server called bi_server1 configured on that WLS, but only an AdminServer.
          If I try to start a non existing managed server (bi_server2) the same way I get:
          +<Oct 10, 2012 2:07:52 PM EEST> <Info> <Management> <BEA-141223> <The server name bi_server2 specified with -Dweblogic.Name does not exist. The configuration includes the following servers {AdminServer,bi_server1}.>+

          You can check what is configured in your domain by reviewing <DOMAIN_HOME>\config\config.xml file (look for the <server> tags) but I think you have only
          +<server>+
          +<name>AdminServer</name>+